96 gauge cluster in 97 tbird done!!! - Page 2 - TCCoA Forums

Reply
 
LinkBack Thread Tools
post #31 of 64 (permalink) Old 11-13-2003, 03:03 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
hey guys. i didnt get a chance to do it today, i'll probly get it done on sunday though. i picked up the oil sending unit today, can someone tell me if this is the correct part # E9SZ-9278-A. The guy at the ford dealer didnt know what he was talkin about and i just want to make sure this is the right one before i install it. Thanks for all the help so far, i cant wait to get this done.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #32 of 64 (permalink) Old 11-13-2003, 04:41 PM Thread Starter
4th Gear Poster
 
Fast96Tbird's Avatar
 
Join Date: Nov 2002
Location: North Carolina
Age: 31
Posts: 337
well just keep us posted on everything, im eager to hear how everything turns out for you

-Derrick-
Fast96Tbird is offline  
post #33 of 64 (permalink) Old 11-16-2003, 03:24 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
i just finished, it was pretty easy with the pin out diagrams, thanks johnny. Thanks for the help with the 4 wires i was confused with fast96. The check gauges light came on and wont go off but i'm assuming thats becuase the oil preasure gauge isnt working since i didnt install the new sending unit yet. all the other guages work fine. Just have to figure out how to get the mileage to match mine. Anyone know how to do this? Thanks for all the help guys, i always thought this couldnt be done when in fact its an extremely easy mod. thanks again

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #34 of 64 (permalink) Old 11-16-2003, 04:19 PM
3rd Gear Poster
 
Join Date: Dec 2002
Location: Aurora/Carbondale IL
Age: 31
Posts: 162
Send a message via AIM to ChitownLX
This is going to sound extremely ignorant/stupid but how do you attach the wires to the new plugs? Is it just as simple as pushing the wire into the plug or is there some kind of sodering that needs to take place?

16.856 @ 80.47mph..... go v6 go!
ChitownLX is offline  
post #35 of 64 (permalink) Old 11-16-2003, 04:25 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
you dont push the wires into the new plugs. i cut off the 97 harnesses and got the 96 harness from a junkyard with about 1 foot of wires on it. then i just used wire connectors to connect the 97 wires to the 96 wires following the diagrams above. It was really easy, it only took me about 90 minutes form start to finish. Now i'm just tryin to figure out how to correct the mileage on the 96 odometer to match the mileage i had on my 97 odometer. I'm hopin to use the money i get from selling my 97 cluster to buy a sc speedo and another set of white gauges.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #36 of 64 (permalink) Old 11-21-2003, 08:51 PM
PostWhore
 
ZackG's Avatar
 
Join Date: Jul 2002
Location: SW PA
Age: 35
Posts: 1,798
Send a message via AIM to ZackG Send a message via Yahoo to ZackG
the SC speedo dont work :-(
you have to use a 96-97 (i believe) SHO speedo

97 Tbird 4.6
VT built block, fox lake PI heads
Vortech at XY psi
4.10's, KB boost a spark.
Yummy.
http://www.cardomain.com/ride/2147246
ZackG is offline  
post #37 of 64 (permalink) Old 11-21-2003, 11:40 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
Quote:
Originally posted by ZackG
the SC speedo dont work :-(
you have to use a 96-97 (i believe) SHO speedo
i have the older gauge cluster now, thats what this thread is about switching the pre 97 cluster into a 97. the sc sppedo will work for my application. You only need the 96-99 sho speedo if you plan to stay with the 97 cluster.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #38 of 64 (permalink) Old 11-22-2003, 04:10 AM
PostWhore
 
ZackG's Avatar
 
Join Date: Jul 2002
Location: SW PA
Age: 35
Posts: 1,798
Send a message via AIM to ZackG Send a message via Yahoo to ZackG
thats my bad, i dont know what i was thinking at the time. I knew what i typed didnt sound completely right.

97 Tbird 4.6
VT built block, fox lake PI heads
Vortech at XY psi
4.10's, KB boost a spark.
Yummy.
http://www.cardomain.com/ride/2147246
ZackG is offline  
post #39 of 64 (permalink) Old 11-23-2003, 08:51 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
it was finally nice enough outside today to do the oil sending unit. so all the gauges are working now. only thing i notcied that doesnt seem right is the wanring ding (sound like ding, ding, ding, ding...) you get when you shut the car off and leave your lights on or something like that is constant if the either one of the doors is open. even if the keys arent in the ignition. it was like this even before the new sending unit, anyone know what could be causing this. any help is appreciated.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #40 of 64 (permalink) Old 11-25-2003, 03:14 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
ok, well everything is finally done. i got the 145 mph speedo installed and the new sending unit installed and everything is working. i couldnt figure out the dinging problem so i just unplugged the dinger, its useless anyway. last thing i gotta do is drill out a new hole in my new dash bezel for my alarm led and then its all done. thanks for all your help. i'll post some pics when i get around to drilling out that hole.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #41 of 64 (permalink) Old 12-15-2003, 07:10 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
finally got around to taking some pics. only took me a month, haha. here's the thread i started. Thread

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #42 of 64 (permalink) Old 12-15-2003, 08:27 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
also, i think i figured out why my car keeps dinging no matter what every time my door is open. i didnt hook my door ajar wire up to anything, i just taped it off cuz the 96 cluster doesnt have a door ajar light. could this cause it? what did you guys hook your door ajar wire up to?

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #43 of 64 (permalink) Old 08-07-2004, 01:16 AM
Drag racing with Jesus
 
Join Date: Jul 2002
Location: Vermilion Ohio
Age: 62
Posts: 654
Quote:
Originally posted by fdawg97lx
also, i think i figured out why my car keeps dinging no matter what every time my door is open. i didnt hook my door ajar wire up to anything, i just taped it off cuz the 96 cluster doesnt have a door ajar light. could this cause it? what did you guys hook your door ajar wire up to?

Frank
HI Frank

Did you solve the dinging problem ? I am getting ready to install my 96 cluster.
What size wire connectors should I use ?

Thanks Curt

Curtis Carter - July 14, 1954 to June 4, 2006 -- RIP Brother, you will be missed

MODS=SCT tuned/J-Mod/Trans Cooler/Dyno max Cat-Back/NgkPlugs/Mac cold air/March UD's/FRPP aluminumcarrier3.73's "SOLD CAR"
PI cams + PI intake manifold w/adapter plate
Mark VIII Convertor/80mm L-Maf/70mm TB
Mark VIII 1 piece shaft/Cobra R' wheels/
Kumhos 235/60/16 - White leather w/ blue
cloth seats - white face gauges in 95 cluster
LST MN-12 is offline  
post #44 of 64 (permalink) Old 08-07-2004, 05:57 AM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
Quote:
Originally posted by LST MN-12


HI Frank

Did you solve the dinging problem ? I am getting ready to install my 96 cluster.
What size wire connectors should I use ?

Thanks Curt
my car still dings when the drivers door is open. i think the wires are 16 gauge. i used the blue ones i think they are good for 16-18 gauge.

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #45 of 64 (permalink) Old 08-07-2004, 10:40 AM
Drag racing with Jesus
 
Join Date: Jul 2002
Location: Vermilion Ohio
Age: 62
Posts: 654
Thank You If I can solve the dinging problem I will post back


Curt

Curtis Carter - July 14, 1954 to June 4, 2006 -- RIP Brother, you will be missed

MODS=SCT tuned/J-Mod/Trans Cooler/Dyno max Cat-Back/NgkPlugs/Mac cold air/March UD's/FRPP aluminumcarrier3.73's "SOLD CAR"
PI cams + PI intake manifold w/adapter plate
Mark VIII Convertor/80mm L-Maf/70mm TB
Mark VIII 1 piece shaft/Cobra R' wheels/
Kumhos 235/60/16 - White leather w/ blue
cloth seats - white face gauges in 95 cluster
LST MN-12 is offline  
post #46 of 64 (permalink) Old 08-10-2004, 02:39 PM
3rd Gear Chirper
 
hotbird's Avatar
 
Join Date: Dec 2002
Location: Englewood FL
Age: 32
Posts: 2,399
If you are going to purchase an oil sending unit, I recommend that you get the one from NAPA, and then solder a jumper lead over the resistor behind the oil gauge. This will give your gauge functionality instead of just being able to read Normal or Low. Let me knw if you need the NAPA part number.

Also, the lead for the door ajar chime is grounded thru the ignition lock cylinder to sound the chime. Pull the lock cylinder out and see if the contact is stuck or shorted to ground. Better yet, cut the wire and be dinger-free forever. (Except for headlight reminder chime, that'll still work.)
hotbird is offline  
post #47 of 64 (permalink) Old 08-10-2004, 05:24 PM
Drag racing with Jesus
 
Join Date: Jul 2002
Location: Vermilion Ohio
Age: 62
Posts: 654
Quote:
Originally posted by hotbird
If you are going to purchase an oil sending unit, I recommend that you get the one from NAPA, and then solder a jumper lead over the resistor behind the oil gauge. This will give your gauge functionality instead of just being able to read Normal or Low. Let me knw if you need the NAPA part number.

Yes - need part# and what color wire is to cut !!! Thanks Curt

Also, the lead for the door ajar chime is grounded thru the ignition lock cylinder to sound the chime. Pull the lock cylinder out and see if the contact is stuck or shorted to ground. Better yet, cut the wire and be dinger-free forever. (Except for headlight reminder chime, that'll still work.)

Curtis Carter - July 14, 1954 to June 4, 2006 -- RIP Brother, you will be missed

MODS=SCT tuned/J-Mod/Trans Cooler/Dyno max Cat-Back/NgkPlugs/Mac cold air/March UD's/FRPP aluminumcarrier3.73's "SOLD CAR"
PI cams + PI intake manifold w/adapter plate
Mark VIII Convertor/80mm L-Maf/70mm TB
Mark VIII 1 piece shaft/Cobra R' wheels/
Kumhos 235/60/16 - White leather w/ blue
cloth seats - white face gauges in 95 cluster
LST MN-12 is offline  
post #48 of 64 (permalink) Old 08-10-2004, 07:09 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
Quote:
Originally posted by hotbird

Also, the lead for the door ajar chime is grounded thru the ignition lock cylinder to sound the chime. Pull the lock cylinder out and see if the contact is stuck or shorted to ground. Better yet, cut the wire and be dinger-free forever. (Except for headlight reminder chime, that'll still work.)
sweet. i'm gonna cut that tomorrow. so that wire is meant for nothing more than the door ajar dinger?

Frank

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #49 of 64 (permalink) Old 08-17-2004, 08:33 AM
PCD
Confirmed V6 Nut
 
Join Date: Aug 2002
Location: Dubuque, Iowa
Age: 60
Posts: 2,261
Is the 96 sender all I need for an electric gauge for the oil pressure? I'm planning a triple A pillar pod for my 97. (Oil Pressure, Water Temp, and Trany Fluid Temp).

The Parts Bin Special is DEAD! It is being parted out.
PCD is offline  
post #50 of 64 (permalink) Old 08-24-2004, 01:28 PM
Drag racing with Jesus
 
Join Date: Jul 2002
Location: Vermilion Ohio
Age: 62
Posts: 654
I did the swap and some how smoked my alternator Any Ideas on
how I screwd the wiring up


connected all Black #57 grounds from 1996 to the 1 ground from 1997
also I had some doubt about "Light Green w/ Red" wires as one seemed off color


Curt

Curtis Carter - July 14, 1954 to June 4, 2006 -- RIP Brother, you will be missed

MODS=SCT tuned/J-Mod/Trans Cooler/Dyno max Cat-Back/NgkPlugs/Mac cold air/March UD's/FRPP aluminumcarrier3.73's "SOLD CAR"
PI cams + PI intake manifold w/adapter plate
Mark VIII Convertor/80mm L-Maf/70mm TB
Mark VIII 1 piece shaft/Cobra R' wheels/
Kumhos 235/60/16 - White leather w/ blue
cloth seats - white face gauges in 95 cluster
LST MN-12 is offline  
post #51 of 64 (permalink) Old 09-30-2004, 05:13 AM
Hag
1st Gear Poster
 
Join Date: Sep 2004
Location: San Antonio, TX
Age: 45
Posts: 57
I'm attempting to change out a standard cluster in a 1991 bird for an LX cluster from a 1991 bird. Will the diagrams above apply? They seem to be different from my application. Where were those diagrams found at? I'd like to get a hold of software like that. Thanks in advance.

Hag
Hag is offline  
post #52 of 64 (permalink) Old 11-20-2005, 11:24 PM
The Band, not the Disease!
 
AnthraxBird's Avatar
 
Join Date: Jul 2002
Location: NW Indiana
Age: 32
Posts: 3,090
Send a message via AIM to AnthraxBird
Sorry for ressurecting. I am doing this swap, but I want the idiot lights that go beneath the radio. I am going to pull the parts out of a junkyard bird with the VMM. I know I need the pigtails, plastic trim piece, the actual cluster, etc. Now my question. What do I need to get from the donor bird so I can make the VMM work???

1997 Mark VIII LSC - Toreador Red
AnthraxBird is offline  
post #53 of 64 (permalink) Old 11-20-2005, 11:27 PM
Formerly Fdawg97LX
 
Fdawg03SVT's Avatar
 
Join Date: Jul 2002
Location: Medford, MA
Age: 34
Posts: 3,186
Send a message via AIM to Fdawg03SVT
Quote:
Originally Posted by AnthraxBird
Sorry for ressurecting. I am doing this swap, but I want the idiot lights that go beneath the radio. I am going to pull the parts out of a junkyard bird with the VMM. I know I need the pigtails, plastic trim piece, the actual cluster, etc. Now my question. What do I need to get from the donor bird so I can make the VMM work???

i would assmue you'd need the pig tail for the vmm also. then just run the wires for the idot lights from the 97 cluster harnesses to the vmm pig tail.

2007 Dodge Ram 1500
2008 Suzuki GSX-R1000

Previous Rides:
2003 Suzuki GSX-R750
2003 Mustang Cobra 10th Anniversary - 11.2 @ 130
1997 Thunderbird LX 4.6 - 13.7 @ 103
1993 Thunderbird LX 3.8 - Slow
1990 Thunderbird 3.8 - Slower
Fdawg03SVT is offline  
post #54 of 64 (permalink) Old 11-21-2005, 12:54 PM
PostWhore
 
Join Date: Apr 2003
Location: O'Fallon, MO
Age: 36
Posts: 1,411
Quote:
Originally Posted by hotbird
If you are going to purchase an oil sending unit, I recommend that you get the one from NAPA, and then solder a jumper lead over the resistor behind the oil gauge. This will give your gauge functionality instead of just being able to read Normal or Low. Let me knw if you need the NAPA part number.
I would recommend AGAINST a Napa sending unit... I got one from them, and it leaked, got a replacement and I was having non-stop issues with the guage (would drop to zero, and go back up, randomly). Got a Motorcraft sending unit from Dan when I did the PI swap and haven't had a problem since.

'95 Cougar - 2002 Explorer engine, 2004 Mustang PTP2 PCM

Best times:
PI 4.6L 95 XR7 Cougar: 14.68@94MPh
2004.5 Silverado Crew Cab/Long Bed/4x4 6.6L Duramax: 14.067@96.29MPh (Weighing in at over 7200#) on 10/19/2007
Dyno - 446.4RWHP/820.2RWTq on 6/13/2008
Pulling - 300.9' 3rd place finish 8/2011
Cougar281 is offline  
post #55 of 64 (permalink) Old 11-28-2005, 03:48 PM
The Band, not the Disease!
 
AnthraxBird's Avatar
 
Join Date: Jul 2002
Location: NW Indiana
Age: 32
Posts: 3,090
Send a message via AIM to AnthraxBird
Are the 93 - 95 guages the same thing as the 96's?

1997 Mark VIII LSC - Toreador Red
AnthraxBird is offline  
post #56 of 64 (permalink) Old 11-28-2005, 03:58 PM
Who is John Galt?

Moderator
 
Join Date: Sep 2004
Location: West of the Atlantic
Posts: 6,476
Quote:
Originally Posted by AnthraxBird
Sorry for ressurecting. I am doing this swap, but I want the idiot lights that go beneath the radio. I am going to pull the parts out of a junkyard bird with the VMM. I know I need the pigtails, plastic trim piece, the actual cluster, etc. Now my question. What do I need to get from the donor bird so I can make the VMM work???
just curious, you happen to have a cubby and rubber mat you'd be looking to unload?

"Won't work, can't be done"
cougar_guy04 is offline  
post #57 of 64 (permalink) Old 11-28-2005, 04:08 PM
The Band, not the Disease!
 
AnthraxBird's Avatar
 
Join Date: Jul 2002
Location: NW Indiana
Age: 32
Posts: 3,090
Send a message via AIM to AnthraxBird
I just got back from the junkyard, and I was going to buy one out of a 96, but I didn't =/ I dont have one, I have the ash tray + the cigar lighter combo beneath my radio as of right now. If you really want it I can go get it for ya =)

1997 Mark VIII LSC - Toreador Red
AnthraxBird is offline  
post #58 of 64 (permalink) Old 07-21-2011, 11:04 PM
Veteran Poster
 
GRNDPNDR's Avatar
 
Join Date: Dec 2009
Location: Ontario, Canada
Age: 34
Posts: 811
Somewhere on this site i posted an excel sheet pinout that has the two charts side by side to basically look at and see which pin goes where.

Not sure where it is but it was a while back. I think I had a thread on it too maybe but I've yet to get around to doing this.

Rest In Peace Mom.
GRNDPNDR is offline  
post #59 of 64 (permalink) Old 07-21-2011, 11:35 PM
Seasoned PostWhore
 
Traveler's Avatar
 
Join Date: Feb 2003
Location: Parsons KS
Age: 54
Posts: 9,164
Garage
Send a message via Yahoo to Traveler
If I don't find a cluster surround for my 97, I may HAVE to do this swap! Honestly, I don't mind the 97 style gauges at all. I have the SHO cluster.


1997 Thunderbird Sport
Low Miles
Wifes Car
destined to remain stock

1997 T-Bird GT 4.6
80 MM Mustang GT MAF - P&P'd Mustang GT TB and Intake Plenum - PI Intake manifold - PI Heads
Mark VIII Torque Converter - J-Modded 4R70W transmission - Mark VIII Aluminum Driveshaft - 3.73 gears
PBR Brake Calipers - Eibach Springs - KYB Shocks
'89 SuperCoupe front and rear sway bars
SCT Chip programmed by Lonnie Doll
255/50/16 Falken Ziex ZE-512's
True Dual exhaust with Magnaflow DI/DO muffler
<<< SOLD >>>
Traveler is offline  
post #60 of 64 (permalink) Old 07-22-2011, 12:06 AM
PostWhore
 
1996Project-bird's Avatar
 
Join Date: Mar 2010
Location: NJ
Age: 25
Posts: 1,485
Quote:
Originally Posted by Traveler View Post
If I don't find a cluster surround for my 97, I may HAVE to do this swap! Honestly, I don't mind the 97 style gauges at all. I have the SHO cluster.
I know there's one in a yard near me from a 97. I pulled the cupholders and radio surround and they were in good shape. No reason the cluster surround would be any different. If you're interested let me know and I'll get a price.

I love my V8, but I'd love it more if all 8 cylinders worked. (they do now)

My T-bird is like George Jetson's wife, you try to give her a little money, she takes the whole wallet.
1996Project-bird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome