97 4r70w rebuild problems - TCCoA Forums

 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-06-2017, 07:19 PM Thread Starter
1st Gear Poster
 
Join Date: Aug 2012
Location: Seminole, Fl
Age: 37
Posts: 49
97 4r70w rebuild problems

I just rebuilt my 97 trans in my car. I updated to the mechanical diode, jmod , all new pistons and solenoids. I am having a stange problem now that its back together. It shift fine under throttle all the way into od. When I lift off the gas it seems to jump hard out of od back into third for a few seconds then back into od. It does this every time I let off the throttle, otherwise shifts fine. If anyone has any ideas on where to start diagnosing this thing I would appreciate it. Thanks
Robe is offline  
post #2 of 2 (permalink) Old 03-14-2017, 08:57 PM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 51
Posts: 2,959
Are you sure it isn't the torque converter unlocking and re-locking? I can't think of many reasons it would drop back into 3rd unless maybe there is an issue with the MLPS or TPS.

Also, please tell me that you aren't going full throttle into overdrive.

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome