Boost - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 22 (permalink) Old 01-29-2008, 07:20 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
Boost

Is there any reason my boost gauge would just stop reading?.......I worked fine when I got it....

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 01-29-2008, 09:55 PM
2nd Gear Poster
 
Gonzo's Avatar
 
Join Date: Oct 2006
Location: WI
Posts: 61
The hose probably popped off the back off the guage. You need to pull the guage cluster and make sure it's still connected.

Steve

1993 LX converted to a 5.0/5 speed - Mac long tubes - SCT Pro Racer tuned by Lonnie and me - best E.T. 14.88 - mph 94.59

1991 SC - Stock..........Mostly
Gonzo is offline  
post #3 of 22 (permalink) Old 01-30-2008, 11:23 AM
 
Join Date: Jul 2002
Posts: 185
check vac ?boost line at back of retrun plenum near brakes it may have fell off or the usual it broke somewhere near or behind brake unit
mannysc is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 01-30-2008, 03:41 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
Now im really concerned.....my car will not idle very long it dies......when i come to a stop sign it dies before i can put it in first!!! HELP

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #5 of 22 (permalink) Old 01-30-2008, 04:24 PM
2nd Gear Poster
 
Gonzo's Avatar
 
Join Date: Oct 2006
Location: WI
Posts: 61
Did you check the boost line in the 2 places that were recommended? That would cause the problems you are explaining.

Steve

1993 LX converted to a 5.0/5 speed - Mac long tubes - SCT Pro Racer tuned by Lonnie and me - best E.T. 14.88 - mph 94.59

1991 SC - Stock..........Mostly
Gonzo is offline  
post #6 of 22 (permalink) Old 01-30-2008, 07:13 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
that would cause the no read on the gauge and the stall?

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #7 of 22 (permalink) Old 01-30-2008, 07:29 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
lol even quicker q.........does the upshift light actually work?

Mine never lights up when driving only when starting

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #8 of 22 (permalink) Old 01-30-2008, 09:46 PM
2nd Gear Poster
 
Gonzo's Avatar
 
Join Date: Oct 2006
Location: WI
Posts: 61
that would cause the no read on the gauge and the stall?

Yes it would, the guage has no reference and it causes a vacuum leak when disconnected.

1993 LX converted to a 5.0/5 speed - Mac long tubes - SCT Pro Racer tuned by Lonnie and me - best E.T. 14.88 - mph 94.59

1991 SC - Stock..........Mostly
Gonzo is offline  
post #9 of 22 (permalink) Old 01-30-2008, 10:21 PM
Seasoned PostWhore
 
rbrown's Avatar
 
Join Date: Aug 2002
Location: Houston Clear Lake
Posts: 7,059
Quote:
Originally Posted by Gonzo View Post
that would cause the no read on the gauge and the stall?

Yes it would, the guage has no reference and it causes a vacuum leak when disconnected.
Like he said.

And there is a shift light???

95 SC 5-speed The Toy in Storage now.
95 SC Auto Newest storage queen.
91 Festiva 1.3L baby 5 speed
03 Crown Vic Sport 4.6... driver
10 Flex Brick Twin Turbos
*Rodney*
rbrown is offline  
post #10 of 22 (permalink) Old 01-30-2008, 10:28 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
yeah it's an arrow pointing up in the tach....it lights when i turn the car on but not when i drive

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #11 of 22 (permalink) Old 02-01-2008, 12:36 PM
3rd Gear Poster
 
Old_coot's Avatar
 
Join Date: Sep 2003
Location: Kentucky
Age: 72
Posts: 180
Send a message via Yahoo to Old_coot
If you wind the engine up to high the shift light will come on.If memory serves me right mine comes on anytime I go over 5000rpms...............Dan
Old_coot is offline  
post #12 of 22 (permalink) Old 02-01-2008, 04:09 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
lol I fixed the gauge.....anytime i got on it the damn hose pulled off of the supercharger....

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #13 of 22 (permalink) Old 02-01-2008, 04:22 PM
2nd Gear Poster
 
Gonzo's Avatar
 
Join Date: Oct 2006
Location: WI
Posts: 61
Glad to hear you got it fixed

Steve

1993 LX converted to a 5.0/5 speed - Mac long tubes - SCT Pro Racer tuned by Lonnie and me - best E.T. 14.88 - mph 94.59

1991 SC - Stock..........Mostly
Gonzo is offline  
post #14 of 22 (permalink) Old 02-02-2008, 03:29 AM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
lol this may sound stupid but I want my supercharger to be louder.... I read earlier that you can weld the sound ports shut to kill the whine......but I wanna go opposite with it

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #15 of 22 (permalink) Old 02-02-2008, 11:40 AM
PostWhore
 
David Neibert's Avatar
 
Join Date: Jan 2004
Location: St. Charles MO
Posts: 1,324
Quote:
Originally Posted by Essex8800 View Post
lol this may sound stupid but I want my supercharger to be louder.... I read earlier that you can weld the sound ports shut to kill the whine......but I wanna go opposite with it
Closing the sound ports makes it louder, not quieter. Easiest way to get more supercharger whine is to change to a cold air intake that uses a steel or aluminum pipe.

David

1991 SC AOD 4.2..2.3 Whipple..........10.910 @ 125.61
2016 SRT Challenger Hellcat..................707HP/650TQ
David Neibert is offline  
post #16 of 22 (permalink) Old 02-10-2008, 04:47 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
I need to ask another q....I hear a loud knock coming from my engine on hard acceleration, kinda sounds like my lifters but it doesnt do it at idle.....My dad said something about the throw out bearing but thought id ask on here too.....oh and does anyone know where i can find a set of bolts that holds the supercharger top on.....someone replaced mine and there is a leak around the top now.

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #17 of 22 (permalink) Old 02-10-2008, 04:54 PM
13's or Mildly Broken
 
Join Date: Jul 2002
Location: Blair, Nebraska
Age: 36
Posts: 2,670
If theres a vac leak around the blower top - pull it off and reseal it with Copper RTV or a good gasket if you can find one. New bolts may help, but won't totally cure the problem.

If you want to make the blower whine more noticeable, replace the stock rubber intake tube with an aluminum one. It will definiately be noticeable after that.

Loud knock could be a bearing maybe? I remember a knock when the bearing went out on my dad's 94 SC.

-Melon

1994 Thunderbird SC 3.8L Supercharged
1999 Crown Victoria P71 4.6
2000 Explorer 5.0
Melon is offline  
post #18 of 22 (permalink) Old 04-04-2008, 07:18 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
I think my cat is rattling......man this car is bein a real pain...lol.....Would the cat cause my car to overheat or die if its clogged? cause its been doin that lately.....I've also noticed a huge reduction in power....but i cant afford to get all new cats!!! what to do???

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #19 of 22 (permalink) Old 04-05-2008, 07:51 PM
 
Join Date: May 2005
Posts: 156
Yes the cats being plugged and breaking up will defanitely do that. My 4.6 did that too. I would check the prices on high flow cats. they are cheaper than you think. I took mine to a muffler shop, had 2 new cats and mufflers put on for just over $300
Robert M is offline  
post #20 of 22 (permalink) Old 04-06-2008, 01:14 PM Thread Starter
5th Gear Poster
 
Essex8800's Avatar
 
Join Date: Dec 2006
Location: Gallatin, TN
Age: 31
Posts: 410
Send a message via AIM to Essex8800
I checked fractory replacement and it was $500....

1990 35th Anniversary Edition
My new project
Essex8800 is offline  
post #21 of 22 (permalink) Old 04-07-2008, 05:48 AM
 
Join Date: May 2005
Posts: 156
Quote:
Originally Posted by Essex8800 View Post
I checked fractory replacement and it was $500....
Aftermarket will be less than half i bet
Robert M is offline  
post #22 of 22 (permalink) Old 04-15-2008, 06:42 PM
PostWhore
 
Join Date: Nov 2002
Location: Edmonton, Alberta Canada
Posts: 1,228
Even cheaper if you get them on Ebay and just have someone cut the old ones out and put the new ones in. Don't trash on it with blown cats as you could blow the head gaskets.

The upshift light will come on at higher rpm in high gear. Mine comes on at about 160-180 km/h (100-120 mph).
Flex is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome