Please Help! Balancer Install - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 06-27-2003, 01:42 PM Thread Starter
 
Join Date: Nov 2002
Posts: 127
Please Help! Balancer Install

I have searched every thread and I am in a pickle getting this damn balancer back on (stock). It's a nightmare for a first-timer with little automotive experience. I have been working on it for three days and through last night.

Okay, I got through every hurdle but this on. I have the installer tool (OEM form Autozone) w/ thrust bearing and all, but how EXACTLY does it work. Our balancers have an indention and I can't get around the free nut to turn it, plus its too big!

I have the proper adapters and it fits well in the crank snout, all pieces are there, I just can't get to that nut.

Anyone, please I have to leave on a long trip tomorrow morning; only car!

Thanks
talon660 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome