Wirring and DIS problems? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-26-2004, 08:11 PM Thread Starter
 
Join Date: Jan 2004
Posts: 1
Wirring and DIS problems?

I keep blowing up DIS moudls.afer searching here and other boards, I put in a new coil (old one had a burnt terminal) and still doing it. The motor is out of a wreck that I put into a tube chassie race car. So, I've gone through and checked all the wires and grounds. I found a non-insulated ground, inthe harness going the the cam sensor, that does not terminate anywhere/ cut off.
Question 1: Any ideas on the DIS moduals?
Question 2: Where should this ground be going to?

Scott
Rocawl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-09-2004, 08:59 PM
PostWhore
 
seawalkersee's Avatar
 
Join Date: Jan 2004
Location: Outside KCMO
Age: 42
Posts: 1,566
From what I understand there are two major grounds on the supercoupes. Both of them go to the engine mounts. I dont have the stuff here to post the harness pics you need. As far as the DIS module goes. You need to purchase a QUALITY DIS module. Like from Ford not one of the cheep ones from Autozone. If I were you I would try this and if it does not work post on the SCCOA website. Some of those guys have some really good info.
seawalkersee is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome