91 Cougar 5.0 HO o2 Sensor Help? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 07-07-2011, 03:34 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
91 Cougar 5.0 HO o2 Sensor Help?

I have a 1991 cougarLS originally came with the 3.8 and I swapped it out for a 1992 5.0L HO out of a 1992 cougar. My problem is that there seems to only be one o2 sensor plug which is in the driver side header. Isn't there supposed to be more than 1 o2 sensor on the 5.0Ho engine? I used the engine harness. EEC, engine and tranny from the donor car so why isn't there another o2 sensor plug on the passenger side header? Any help is greatly appreciated. Thanks

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 07-08-2011, 06:26 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
Hellllooo? Can anyone help me with this ?

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #3 of 14 (permalink) Old 07-08-2011, 06:53 PM
Kind of slapped together
 
Join Date: Jan 2010
Location: Bossier City, LA
Age: 63
Posts: 4,844
I went and looked at my 91 5.0HO - and the passenger side is in the exhaust pipe between the header flange and the first cat.

So, no, there isn't an O2 sensor in the passenger header. Yes, there ARE two O2 sensors.

I tried to take a pic - hopefully this works good enough:

Driver side:



Passenger side:



Notice the bung and the hint of the O2 sensor at the far right of this pic.

Sorry for the poor quality - this fat white boy couldn't fit under his car with the back end up on the jack stands (doing some fuel line / gas tank work)

RwP
RalphP is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 07-08-2011, 11:13 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
Thank you for taking the time to do that! I know that there is no o2 sensor in the pass header, there is the egr spout. Sorry if I said it the wrong way, what I meant is that I have the o2 sensor and plug for the harness for the drivers side o2 but there seems to be no other o2 sensor or harness plug for( passenger side of the car). where would the other harness plug be for the other sensor? If I could find it then it would be an easy fix just get another o2 and bung, weld it into the pass side exhaust piping and plug her in.

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #5 of 14 (permalink) Old 07-09-2011, 01:17 AM
Kind of slapped together
 
Join Date: Jan 2010
Location: Bossier City, LA
Age: 63
Posts: 4,844
Oh.

I dunno on your harness, mine was hanging off the back of the O2 sensor

(Did the swap laying on my back by feel. Think I did DARN good overall, especially with Rockauto accidently shipping a downstream later-model O2 sensor - same active element, same curves, but a different key on the connector.)

RwP
RalphP is offline  
post #6 of 14 (permalink) Old 07-09-2011, 10:30 AM
PostWhore
 
Join Date: Jul 2002
Location: Canada's Rain Forest
Age: 43
Posts: 1,923
Hmm i'm thinking you didn't take all the wiring.. If i didn't already box up my Manuals (we're moving come the end of this month so less then important things are being boxed up as of now) but i think that passenger side O2 sensor (like most MN12s pre '94?) the passenger side O2 sensor wiring was part of the chassis harness?

take it you don't have the parts car huh?
91 XR7 is offline  
post #7 of 14 (permalink) Old 07-09-2011, 11:02 AM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
Nooo the parts car is lonngggg gone. Probably made into a cell phone or something by now lol. I used the stock V6 chassis harness and just plugged the 5.0HO engine harness into it. Could I splice into the driver side one and add a pass side one or how would I go about doing this?

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #8 of 14 (permalink) Old 07-09-2011, 11:23 AM
PostWhore
 
Join Date: Jul 2002
Location: Canada's Rain Forest
Age: 43
Posts: 1,923
Also the ECU has two inputs for the o2 sensor so it can say which side of the engine is doing what for Air-fuel.

Tapping in for power and ground you may be able to do over at the other O2 sensor, but the other two leads most likely not. since one goes to the ECU so it knows what the passenger side is doing independent of the driver's side. and the last lead, i think you can but i'm not 100% sure

this may be a key reason why you have been having running issues?

too bad you didn't keep the chassis harness from the firewall forward from the parts car. Also the instrument cluster, since if you have a tach it's going to read wrong (easy fix either way thou)
91 XR7 is offline  
post #9 of 14 (permalink) Old 07-10-2011, 10:09 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
Shouldn't the V6 chassis harness or the V6 engine for that matter have had 2 o2 sensors anyways? I have the day off on tues so I'm going to Jack it up and go under to take a look. If there isn't another plug in what should I do to fix it? The 5.0 ECM is in the car so would I have to locate the pins on the harness plug in and just run the signal wires and use the other two grounds for the new one?

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #10 of 14 (permalink) Old 07-12-2011, 03:07 PM
PostWhore
 
Join Date: Jul 2002
Location: Canada's Rain Forest
Age: 43
Posts: 1,923
Okay yes the 3.8L had two O2 sensors

Both the Left and Right Sensors have their power, ground (heater), ECU signal through connector C161 (it's the one near the firewall just to the passenger side of the AC drier/receiver)
BUT the Signal return (read ground really) the passengers O2 gets it from Connector C161, but the Drivers side gets it from Connector C172 which is another connector next to C161

NOW the 5.0L side

Drivers O2 sensor has all four wires going through connector C161 (in the same location as the 3.8L (Pinning/Size may be different?)
But the passenger side goes through connector C112 which is on the chassis just below where the air box is.

NOW did you reuse the MAF sensor harness from the 3.8L or no?
If not (since i think it's attached to the ECU connector) then you may be able to locate the harness that goes from C112 to the O2 Sensor. or create your own? from my EVTM it's only a 4 position plug, so that would mean to me, it only does the O2 sensor on the passenger side

Also wiring in the passenger side O2 won't be the end of the world, Go to the wrecker and cut off the Connector that plugs into the O2 Sensors plug (while leaving a bit of wire still attached, DUH!)

Then Power (heater), Ground (Heater), Signal Return are shared between both, so you can tie in the drivers side for those. the Signal (to EEC) you need to find a way to get it back to pin 44

Passenger O2 wiring
Power (Heater) = Grey with Yellow
Ground (heater) = Black with Light Green
Signal Return = Grey with Red
Signal = Tan With Orange


Good luck
91 XR7 is offline  
post #11 of 14 (permalink) Old 07-12-2011, 07:56 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
I used everything off of the 5.0 HO engine. Everything from the Front bumper to the firewall. Engine, tranny, Rad, Engine harness that pluged through the firewall into the 5.0 computer then pluged my (inside/dash) harness into the harness that also came through the firewall. I believe I used the 5.0 MAF. Now you said that there was the passenger side plug for o2 under the air box right? Can u take a picture of it because I have a 2 lonely plugs , one(2 yellow wires one with a red line and the other with a black line) and two(pink w/ black line, red w/ orange line) but I believe one goes to the ac condenser or w.e that I removed when I took out the whole a/c system.

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #12 of 14 (permalink) Old 07-12-2011, 08:31 PM
PostWhore
 
Join Date: Jul 2002
Location: Canada's Rain Forest
Age: 43
Posts: 1,923
it'll be awhile, and i dought i'll remember, before i see my 5.0L car.. So pictures may not be possible for awhile. but you never know.

Also the Yellow wired plug would most like have something to do with power.
The other one doesn't ring a bell at this time, sorry. and my book is boxed up again

Also the AC pump is on the drivers side, even thou the wiring is coming the passenger side (hey the alternator is on the passenger side, but it's wiring is coming from the drivers side, Makes total sense huh?

But the plug that for the O2 sensor will have 4 wires going to it.. colors may or may not be as i stated above thou, that's for the '91 cars
91 XR7 is offline  
post #13 of 14 (permalink) Old 07-13-2011, 10:15 PM Thread Starter
1st Gear Poster
 
DJKRS1's Avatar
 
Join Date: Mar 2009
Location: Windsor,Ontario
Age: 35
Posts: 49
Okay no problem I'll just use the 3 wires from the driver side(power,ground,sig return) and run the other wire up into the interior and splice it into pin44 on the ECU harness connector. I'm guessing that should take care of the issue. It should be the same as what "should" be there and I'll grab the pass o2 connector plug for a wreakers. Thanks for the help guys, you never dissapoint!

1991 Cougar LS : 5.0L HO Swap, Ported&Polished Intake/Pleanum, E-303 Cam, Ford Racing Dizzy, 9mm Ford Racing Wires, 1.7 Rollers, Crane Rods, EGR Delete, JEGS Equal Length Headers, 2.5" True Duals w/ Super 44 Series Mufflers, Magnaflow Hi-Flo Cats, Custom Cold Air Intake, March U/D Pulley Set, 20" Boss 328 Wheels, 245/35ZR20 BFG, Custom Black Metal Flake Paint, Thunderbird SC Rear Bumper and Sideskirts, Custom Taillights, Clearcorner Lens', Shaved Emblems, Viper 2-way LCD Alarm.

Coming Soon: T64 Turbo System Running 10lbs Boost, 2" Lowering Kit, 42lb Injectors, 255lb/hr Fuel Pump, MSD 6A Ignition, Upgraded/Tuned EEC
DJKRS1 is offline  
post #14 of 14 (permalink) Old 07-17-2011, 05:17 PM
Seasoned PostWhore
 
Chris_Murder's Avatar
 
Join Date: Sep 2006
Location: Las Vegas, Nevada
Posts: 5,407
Send a message via AIM to Chris_Murder
IIRC the passenger side o2 sensor plug is located toward the front near the oil pan on the v6 and they used a long lead to the passenger side piping. I could be wrong though.

-1996 Pearl White Thunderbird 4.6 Sport 4v with many mods:
Current Best: 13.583 @ 103.74 10/2014.
227hp/241tq measured on calibrated mustang dyno, tested at full vehicle simulation with inertia enabled, no number skewing.
-2001 White Ford F-250 Super Duty 6.8 V10, 4-door, 4x4, Limo Tint, BFG KO2's, Bilstein 7100 Remote Reservoir Race Bypass Shocks, 6" Spring lift, Kenwood Double Din, K&N Intake, FlowMaster Exhaust
Amber_Murder's Daily Driver.
-2005 White GMC Sierra 3500 6.6 Duramax, Dually, 4-door, 4x4, Limo Tint, BFG Commercial T/A's, Rancho RS9000XL Shocks, Kenwood Double Din, K&N Intake, Banks Monster Exhaust
Chris_Murder's Daily Driver.
Chris_Murder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome