96 T-Bird lx 4.6 cats plugged or bad 02 sensor?? - TCCoA Forums
 1Likes
  • 1 Post By T6Rocket
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 07-25-2017, 06:26 PM Thread Starter
Newbie
 
thunderbbirdbrad's Avatar
 
Join Date: Dec 2016
Posts: 7
96 T-Bird lx 4.6 cats plugged or bad 02 sensor??

Takes some time to get up speed .. I take it easy and try not to beat on the car.. I've done regular maintenance under the hood but starting to lose power and runs a bit hotter than usual (not over heating). ..still starts everyday and drives but just rolled 100,000 miles and i think the cats our shot or maybe it's the 02 sensors .. how difficult is it to replace the front 02 sensors...???
thunderbbirdbrad is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-25-2017, 08:22 PM
4th Gear Poster
 
Join Date: Mar 2011
Location: Alexandria, Virginia
Posts: 215
Could it not be getting up to speed because of inadequate fuel pressure?
Jim3inVirginia is offline  
post #3 of 9 (permalink) Old 07-25-2017, 11:35 PM Thread Starter
Newbie
 
thunderbbirdbrad's Avatar
 
Join Date: Dec 2016
Posts: 7
It could possibly be a fuel pressure issue..
Im not sure how to diagnose it though.. I put a scanner on it and pulled some codes ... Purge valve, system too rich bank 1, oxygen sensor heater circuit bank 2 sensor 2.. also same oxygen code for bank 1 sensor 2... That's why I thought 02 sensors or possibly plugged cats..
thunderbbirdbrad is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 07-26-2017, 06:36 AM
6th Gear Poster
 
Natesriv's Avatar
 
Join Date: Dec 2016
Location: Kansas City
Age: 49
Posts: 584
Garage
Does a 4.6's fuel rail have a Schroeder valve? I put a FP gauge on my fuel rail. It just sits there and tells me the psi..
Natesriv is offline  
post #5 of 9 (permalink) Old 07-26-2017, 08:31 AM
PostWhore
 
T6Rocket's Avatar
 
Join Date: Nov 2004
Location: Raleigh, NC
Posts: 1,753
I would get Motorcraft o2 sensors. Anything made by Bosch doesn't belong on ANY car.

Al
lurch likes this.

97 T-Bird LX 4.6 - 80k miles
94 Supra TT Auto - street/strip car
04 CVPI- Brenda's car - 76k miles
Previous Fords:
95 T-Bird LX 4.6 - fully optioned, owned 15 years, 220k miles
96 Cougar XR-7 4.6- Brenda's car, owned 11 years, 187k miles
88 T-Bird 3.8 - first T-Bird, owned 5 years, 206k miles
T6Rocket is offline  
post #6 of 9 (permalink) Old 08-28-2017, 07:18 AM
3rd Gear Poster
 
Join Date: Dec 2012
Location: Greenville, sc
Posts: 199
Quote:
Originally Posted by T6Rocket View Post
I would get Motorcraft o2 sensors. Anything made by Bosch doesn't belong on ANY car.

Al
Who do you think makes the OE motorcrafts?... (worked at Bosch's Planar Sensor (02) plant in college.)
Only two Major companies make O2 sensors, Denso and Bosch

The only difference is that going to the OEM for assembly line install get an extra test on them (0 mileage failures are a huge no no with big dollar charge backs). Anything going for aftermarket install is treated the same. (still two levels of tests).

Last edited by son of mad dog; 08-28-2017 at 07:41 AM.
son of mad dog is offline  
post #7 of 9 (permalink) Old 08-28-2017, 08:04 AM
PostWhore
 
T6Rocket's Avatar
 
Join Date: Nov 2004
Location: Raleigh, NC
Posts: 1,753
Any Bosch branded o2 sensor I have ever seen looks different than a Motorcraft sensor.

I am sure they make good products, just haven't found one to date.

Al

97 T-Bird LX 4.6 - 80k miles
94 Supra TT Auto - street/strip car
04 CVPI- Brenda's car - 76k miles
Previous Fords:
95 T-Bird LX 4.6 - fully optioned, owned 15 years, 220k miles
96 Cougar XR-7 4.6- Brenda's car, owned 11 years, 187k miles
88 T-Bird 3.8 - first T-Bird, owned 5 years, 206k miles
T6Rocket is offline  
post #8 of 9 (permalink) Old 08-28-2017, 10:58 AM
6th Gear Poster
 
TwoHaggard's Avatar
 
Join Date: Oct 2006
Location: Ohio
Posts: 555
Garage
Fuel filter? Clean the MAF. East cheap things you should do anywoo!
Tap on the cats with a mallet and see if they make crazy noises. And or pull the front 02 sensors if it runs slightly better the cats may be clogged.

Project still in progress
Explorer engine, vortech v2,intercooled,bullit intake,derale power steering cooler, b&m trans cooler, oil filter relocation, cobra aluminum radiator, Walbro 255 Pump, Intrax 2in lowering springs, KYB front/back,,mark8 Driveshaft, 1.25Rear sway bar, 3:73 aluminum diff, TrackLok, Rear Diff Cover Brace, Sc Wheels 235/60s, Jmodd, Air Bags in Springs,Rear strut Bar,17in Mirror Blk CobraRs, Sc L Brackets, rear torsional load brace, kmember-frame brace, weightloss program, pbr dual pistons drilled/slotted, stainless lines , recaro seats, sct x4 DonL tuned
TwoHaggard is offline  
post #9 of 9 (permalink) Old 08-28-2017, 01:07 PM
3rd Gear Poster
 
Join Date: Dec 2012
Location: Greenville, sc
Posts: 199
Quote:
Originally Posted by T6Rocket View Post
Any Bosch branded o2 sensor I have ever seen looks different than a Motorcraft sensor.

I am sure they make good products, just haven't found one to date.

Al
The cap was a different part no. body is the same as is the internals. For a Ford Motorcraft part we would put one pigtail on (the factory one). For autozone generic we'd cut the testing pigtail off and ship it with various "solder yourself" pigtails.
son of mad dog is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome