engine trouble 84 TC need HELP - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 14 (permalink) Old 08-11-2005, 05:46 AM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
engine trouble 84 TC need HELP

i have a 1984 2.3 turbo coupe i need to get the engine running before truck bash in 2 weeks. All i can tell u is that the car ran real good then one day took a SH*T. The car cranks over but will not run it putters for a sec then dies. It has new plugs and plug wires new starter, new dist. and cap, turbo is fine had it looked at. Also i have no cat. exhust prev owner cut it of could it be the oxygen censor? idk. Do any of u have any suggestions i am open to anything. PLEASE HELP THANKS FOR EVERYTHING.
dada1587 is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 08-11-2005, 10:22 AM
Slacks 12 months a year
TCCoAAC Member
Moderator
 
LX-Tasy's Avatar
 
Join Date: Jul 2002
Location: Jacksonville Fl
Age: 48
Posts: 2,530
Send a message via Yahoo to LX-Tasy
Have you tried the module on the side of the dist.? Also what is your TPS settings? A faulty TPS will cause nightmares.
Good Luck
Chris

"My Other Ride Is Your Girl"
"If Nissan motorsports is Nismo, wouldn't Honda Motorsports be Homo?"
Before the internet, the village idiot would stay in his own village
REAL RACERS DRIVE STRAIGHT TO THE FINISH LINE, WHILE THE OTHERS DRIVE AROUND IN CIRCLES LOOKING FOR IT
05 Supercharged Ranger Edge tuned by www.blueovalchips.com
LX-Tasy is offline  
post #3 of 14 (permalink) Old 08-11-2005, 04:14 PM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
Engine Trouble

thanks for the info i will get right on it to see if that is it how can u tell if the module is bad? thanks and would like some more post in case that is not it.
dada1587 is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 08-12-2005, 09:57 PM
Slacks 12 months a year
TCCoAAC Member
Moderator
 
LX-Tasy's Avatar
 
Join Date: Jul 2002
Location: Jacksonville Fl
Age: 48
Posts: 2,530
Send a message via Yahoo to LX-Tasy
Quote:
Originally Posted by dada1587
thanks for the info i will get right on it to see if that is it how can u tell if the module is bad? thanks and would like some more post in case that is not it.
Whats the results?
Thanks,
Chris

"My Other Ride Is Your Girl"
"If Nissan motorsports is Nismo, wouldn't Honda Motorsports be Homo?"
Before the internet, the village idiot would stay in his own village
REAL RACERS DRIVE STRAIGHT TO THE FINISH LINE, WHILE THE OTHERS DRIVE AROUND IN CIRCLES LOOKING FOR IT
05 Supercharged Ranger Edge tuned by www.blueovalchips.com
LX-Tasy is offline  
post #5 of 14 (permalink) Old 08-12-2005, 11:16 PM
5th Gear Poster
 
Hobohuey's Avatar
 
Join Date: Jun 2005
Location: Catlettsburg, KY
Age: 33
Posts: 443
Have you checked the timing?

'95 T-Bird - Light green, 98 Crown Vic Police Interceptor Engine, 96 Grand Marquis Tranny, 3.27 Trac-loc, Ford MotorSports Trans cooler, Sport Springs, Blaupunkt Richmond, Memphis Car Audio 5x7's, Cerwin-Vega 150.2 powering mids/highs, Volgenhag 4-channel 1200w amp (junk), 2 Memphis Car Audio 12's

'88 T-bird turbo - Silver, 5spd, Rebuilt Engine, t-3 .63, Custom FMIC, Bobs Big Log, Bob's 3" Elbow, Walbro 255lph, Maximum Motorsports Coil-over Kit, Bilstein HD struts, Hypercoil 200# 14" Springs, Caster/Camber Plates, Ranger Roller, Gillis Valve at 20#, 3in. Side-Dump Exhaust, NGK Iridium XI Plugs, Jacobs C-4 Coil, High Volume Oil Pump, MAX PSI Oil Lines, Poly Bushings, 245/50/R16 Nitto 450's, Autocross car
Hobohuey is offline  
post #6 of 14 (permalink) Old 08-13-2005, 02:14 AM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
Engine Trouble

Quote:
Originally Posted by LX-Tasy
Whats the results?
Thanks,
Chris
i am going to the junk yard to get a new TPS. will have resaults monday.
dada1587 is offline  
post #7 of 14 (permalink) Old 08-13-2005, 02:14 AM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
Engine Trouble

Quote:
Originally Posted by Hobohuey
Have you checked the timing?
yes the timming is fine.
dada1587 is offline  
post #8 of 14 (permalink) Old 08-15-2005, 12:40 AM
Newbie
 
Join Date: Mar 2004
Location: Knoxville, TN
Age: 38
Posts: 9
check your fuel pressure if you haven't already
crawdaddy1999 is offline  
post #9 of 14 (permalink) Old 08-18-2005, 10:38 PM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
good news

i just called a junk yard and priced the whole trottle body for $45 i am happy be real happy if that was the problem

Last edited by dada1587; 08-23-2005 at 07:34 PM.
dada1587 is offline  
post #10 of 14 (permalink) Old 08-20-2005, 05:50 PM
3rd Gear Poster
 
Join Date: Jan 2005
Location: Minot ND
Age: 38
Posts: 199
I'd bet on the Ignition Module (on the side of the dizzy). They can be checked at AutoZone on their bench tester. They run around $60 new and are a common problem on all 2.3L

1994 Lx, 93 Mark DOHC engine/trans/driveshaft, H&R springs, tokico blues, 17" ROH Snipers, underdrives, 2.5" true dual w/magnaflow tru-x muffler, 3.73 trac loc, and a older tune that needs redone. Wishing for a t-45 and a power adder. . .
loudpedal99 is offline  
post #11 of 14 (permalink) Old 08-22-2005, 03:35 PM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
need help findin the engine code

need help findin the engine code for my cougar it is not the right engine in it. It is the 84 body style but not the 84 2.3 turbo engine were can i find the engine code thanks and post back asap need car
dada1587 is offline  
post #12 of 14 (permalink) Old 08-22-2005, 06:54 PM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
engine problem

found out one of the major problems the guy i bought the car off of never told me that they did a engine swap it is a 1985 Mercury Cougar XR7 with a 1983 Mustang 2.3 turbo engine so thank and if u know anything about it plz help srry for the incovience
dada1587 is offline  
post #13 of 14 (permalink) Old 08-23-2005, 07:00 AM
3rd Gear Poster
 
TurboCoupe50's Avatar
 
Join Date: Jan 2003
Location: Chesapeake, Va
Posts: 172
I don't think there is any real difference in those 2.3s. The '86 SVO Stangs and Tbird/Xr7s had larger air meters and injectors.

As far as the oxygen sensor it will run without it, so that ain't your problem. The Vane Air Meter and TPS are the only sensors that will keep it from running. You likely have a ignition, fuel pressure problem, or possibly the cam timing has slipped(worn belt)...

1988 Turbo Coupe... 5.0 conversion... AOD... 3.73s
[email protected] W/90hp shot.. [email protected]

1988 Turbo Coupe... White, 5.0 with Trick Flow heads
1988 Turbo Coupe... Bright Red
1993 F150 Lightning... Black.. #249 of 5276
TurboCoupe50 is offline  
post #14 of 14 (permalink) Old 08-23-2005, 07:41 PM Thread Starter
Newbie
 
Join Date: Jul 2005
Location: Indiana
Age: 31
Posts: 10
motor number

hey the motor number is RFE3Z601500 does any one know how to read it i think it is the 83 turbo out of the mustang
dada1587 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome