abs pump? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-17-2006, 03:48 PM Thread Starter
Newbie
 
Join Date: May 2006
Location: NJ
Posts: 4
abs pump?

ok guys... i have a problem with my 88 turbocoupe.. yesterday it started.... when you shut off the key, you hear a noise.. and feel somthing in the pedal slightly... and after looking under the hood.. its this..






anyone ever had one of these go?.. or any idea what its called like.. so if i callup napa, and ask for a price for one?..
dummer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-17-2006, 11:53 PM
3rd Gear Poster
 
Join Date: May 2004
Location: Glenwood IA
Age: 43
Posts: 125
The thing you are pointing to is the accumulator. They are replaceable. key off, pump the brakes at least 25 times to drain the pressure then just unscrew with the Allen head hole on top. As for install, I can't remember if it is just screw it in and go, or if it needs bled.

BE sure that the noise is not the pump motor running because the accumulator itself shoudn't make noises. IF it is the motor running, it could be a bad motor control relay, which is a very common problem.

Dad always said,"Knowledge is limited but stupidity knows no bounds."
YT90SC is offline  
post #3 of 6 (permalink) Old 05-18-2006, 01:42 PM Thread Starter
Newbie
 
Join Date: May 2006
Location: NJ
Posts: 4
with they key off i think it is the motor... cause it sounds like its on, and its trying to do something, but i dont know exactly what... is the relay just a wire? or.. where would i find that?.. thanks though at least i know i might not have to get a whole accumulator
dummer is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-18-2006, 09:48 PM
3rd Gear Poster
 
Join Date: May 2004
Location: Glenwood IA
Age: 43
Posts: 125
it is a relay. I can't remember where it is on a FOX chassis.. I'll look it up tomorrow.

Dad always said,"Knowledge is limited but stupidity knows no bounds."
YT90SC is offline  
post #5 of 6 (permalink) Old 05-18-2006, 10:26 PM
No More BS
 
HotRod88LSC's Avatar
 
Join Date: Jul 2002
Location: Williamsburg
Age: 39
Posts: 538
ya see that brown relay in the top picture, yeah THAT's the abs relay the one above the dipstick and to the right of the egr. Been there done that. GET THE FORD ONE. I dont care who from jason or your own dealer. The aftermarket ones arent worth the money. and will cause more problems that good. TRUST ME.

1988 Lincoln Mark VII
Paxton Novi 1000 6psi kit, 30lb injectors 73mm C&L, MAF converted A3M, gt-40's, Felpro headgaskets, 1.7 Cobra RR's, typhoon intake,1 5/8 shorty headers, off road x-pipe, and full mandrel catback, electric fan, 3.73's, TKO 500, pro 5.0 shifter

372.4hp / 394.6tq 5psi

Rest in Peace Joel R. Bender.
July 30, 1979 - March 26, 2006
HotRod88LSC is offline  
post #6 of 6 (permalink) Old 05-20-2006, 10:52 PM Thread Starter
Newbie
 
Join Date: May 2006
Location: NJ
Posts: 4
thanks guys.. bought one today, works great.
dummer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome