A4ld Trans?? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-31-2013, 11:37 AM Thread Starter
Veteran Poster
 
chris g's Avatar
 
Join Date: Mar 2004
Location: mississippi
Age: 44
Posts: 799
Send a message via Yahoo to chris g
A4ld Trans??

92 ranger is full of fluid but will only try to move when you put it in gear.. whether its forward or reverse. i was told its the front pump.

COLD AIR INTAKE, MN12 PERFORMANCE FRONT SUSPENSION KIT, SILVER PAINTED AVS WINDOW GUARDS, SILVER PAINTED DASH PANELS, 28% MIRROR TINTED WINDOWS, SUSPENSION TECHNIQUES 2'' DROP, TRUE BENDS CUSTOM 2.5'' TRUE DUAL EXHAUST. 2nd generation SC wheels.
chris g is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-31-2013, 12:57 PM
3rd Gear Poster
 
slick59's Avatar
 
Join Date: Dec 2010
Location: Jerseyville, Illinois
Age: 47
Posts: 139
probably so. I had one in my Bronco II. those tranny's are a piece of junk.

I can explain it to you, but I can't understand it for you

Tim

1994 Cougar 3.8L Supercharged
1990 Tbird Supercoupe
slick59 is offline  
post #3 of 5 (permalink) Old 03-31-2013, 02:47 PM
4th Gear Poster
 
97 30th's Avatar
 
Join Date: Apr 2012
Location: Elburn,IL
Age: 55
Posts: 296
Quote:
Originally Posted by slick59 View Post
probably so. I had one in my Bronco II. those tranny's are a piece of junk.
X2 Had one in my 89 Ranger JUNK

You can't fix stupid
97 30th is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-04-2013, 09:10 PM
PostWhore
 
nall_one's Avatar
 
Join Date: Mar 2007
Location: Hickman Nebraska
Age: 31
Posts: 1,273
Garage
only problems we ever had with our 93 ranger was the bell-housing warped, offsetting the convertor in the pump seal and dumping tons of fluid under load. otherwise just driving around she was fine with 31/10.50r15's for 200k+ with regular fluid changes.

wouldn't say its junk, but i wouldn't ever want to own one again either

the lower millage explorer power-train we swapped in has the same problem i guess its a service bulletin as well.

RUST!! eating away at me more than the rear fender wells
95 Deep Jewel Green 40th Anniversary Bird / Stock SOHC 190k 96-97 intake swap, 97 Mk8 4R70W, Jmod, 3L27 / energy susp rear spindle, and cobra arm bushings, 93 Mk8 shaft, and LCAs, 225/60r16 on Windstar twin 5spokes, Vogtland 1.6drop springs, Tokico Blues, PBR, and rear-disk swap, 89 SC swaybars
nall_one is offline  
post #5 of 5 (permalink) Old 05-10-2013, 01:07 PM
1st Gear Poster
 
BIRDMANLX281's Avatar
 
Join Date: Mar 2013
Location: mississippi
Posts: 53
i talked to a friend of mine and he said its either the front pump or torque converter.. anybody got any ideas??

lowered 1.5'' with vogtlands,, tokico ''blues'' on all 4 corners... 28% mirror tinted windows,, P.I.Intake swapped,, S.C side skirts and rear bumper..
BIRDMANLX281 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome