Broke my tranny?! Expert advice please! LONG - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 09-23-2003, 12:32 PM Thread Starter
Rob
Seasoned PostWhore
 
Rob's Avatar
 
Join Date: Jul 2002
Location: Hubbard, TX
Age: 37
Posts: 3,902
Send a message via AIM to Rob
Unhappy Broke my tranny?! Expert advice please! LONG

Dont flame me! I was just screwing around with my tranny. I should've taken more care (and installed the pump with the tranny out of the car), but I didn't. I have been having less than spectacular performance from my car lately and I have to wonder if it's not caused by my recent tranny "experience." BTW, I plan on getting a '98 5.4 truck tranny sometime soon. Anyway, I was rebuilding my engine and was TIRED of my front pump O-ring leak from my tranny. So I removed the front pump from the tranny while it was in the car, installed the new o-ring, started putting it back together...heard something pop, i think because I didn't pull down the bolts evenly on the pump. Well, we tried to push the car, moved it about 5 feet with lots of grinding noises. So I determined that I had screwed something up in the tranny. I got out my homemade slide hammer, pulled the pump back out, and saw this metal plate just sitting out of place in there(i think its called a pressure plate...there are similar plates behind it that seem to have clutch surface on them). Anyway, these "plates" fit into these lateral "grooves" cut into the tranny case I guess these grooves keep them from spinning on their own. However, the front pressure plate fell out while installing the new pump and got forced into the case when we pushed the car, and made some marks on the case, i sanded down the few burrs on the pressure plate that this caused, put it back in the right spot, and put in the pump, with the case still slightly scored. The pump threads seem to have screwed up, so I screwed the pump in as best as I could and JB welded the heads still. Now I still have some sort of a leak from the same area, and my performance seems like it should be better than it is. Would a fairly slow leak around the pump hurt performance? Would a pump not tightened down enough hurt performance? Thanks!
-Rob

-Rob
RIP '94 Amber Fire Pearl Metallic Thunderbird on Bullitts [email protected]
96 Sport '02 Explorer PI with ported heads, 90MM LMAF, DirtyDog Marauder TC, Lasota tune, Jmod, Magnaflow mid-mount with X, no cats. Urethane drivers motor mount. HIDs!
Rob is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-24-2003, 10:54 AM
 
Join Date: Jul 2002
Posts: 286
Check your line pressure when the tranny is fully warm. If its inside the specs in the tranny book, you're good to go if you don't mind the leak.
bill_s is offline  
post #3 of 6 (permalink) Old 09-24-2003, 12:51 PM Thread Starter
Rob
Seasoned PostWhore
 
Rob's Avatar
 
Join Date: Jul 2002
Location: Hubbard, TX
Age: 37
Posts: 3,902
Send a message via AIM to Rob
How do I test line pressure? Also, do you know the pressure specs for '94-5? I was reading around the other day about a surface on the back of the pump that can effect pressure, and since my pump is only held in by two bolts( the rest are basically stripped and jbwelded to the pump ), I'm thinking that this could be my problem. Would low line pressure make my car extremely slow for my mods? There are V6 birds at higher elevations that run better 1/8th times. Thanks
-Rob

-Rob
RIP '94 Amber Fire Pearl Metallic Thunderbird on Bullitts [email protected]
96 Sport '02 Explorer PI with ported heads, 90MM LMAF, DirtyDog Marauder TC, Lasota tune, Jmod, Magnaflow mid-mount with X, no cats. Urethane drivers motor mount. HIDs!
Rob is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 09-24-2003, 08:57 PM
 
Join Date: Jul 2002
Posts: 286
You need a 300 psi gauge on the test port, which is the only pipe plug on the driver's side of the tranny case, and you need to get the Ford tranny book or full service manual for your year to get the pressures normal for different situations.

The world needs a $25 electronic pressure transducer, but the cheapest one I could find that would stand 300 psi cost 90 bux. Its a lot easier to run wires than a pressure line.
bill_s is offline  
post #5 of 6 (permalink) Old 09-24-2003, 09:20 PM Thread Starter
Rob
Seasoned PostWhore
 
Rob's Avatar
 
Join Date: Jul 2002
Location: Hubbard, TX
Age: 37
Posts: 3,902
Send a message via AIM to Rob
What was that about an Electronic Pressure Transducer? Thanks
-Rob

-Rob
RIP '94 Amber Fire Pearl Metallic Thunderbird on Bullitts [email protected]
96 Sport '02 Explorer PI with ported heads, 90MM LMAF, DirtyDog Marauder TC, Lasota tune, Jmod, Magnaflow mid-mount with X, no cats. Urethane drivers motor mount. HIDs!
Rob is offline  
post #6 of 6 (permalink) Old 09-28-2003, 11:13 PM
 
Join Date: Jul 2002
Posts: 286
Rob: Electronic pressure transducer, expensive word for a device like the oil pressure sender for a gauge.

EPDs translate pressure into a voltage, and are very accurate, 1 part in a 1000 is easy. The output voltage usually has to be scaled properly before it goes to a readout like a digital voltmeter. The cheapest versions are just as accurate, but you have to build some electronics to interface them to a meter.

You can get 100 psi plastic transducers for $25 or so, but they won't take much heat, and they won't tolerate the nearly 300 psi seen at the line pressure port of these trannys. The one I used on my tranny was about $95, came from Digikey, is solid SS, and required some outboard electronics.
bill_s is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome