Repair for 1-2 accumulator bore - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 10-02-2003, 12:56 AM Thread Starter
PostWhore
 
Join Date: Nov 2002
Location: SouthEastern PA
Posts: 1,112
Repair for 1-2 accumulator bore

http://www.omegamachine.com/db/hard_parts.asp

Scroll down to the "Cases" section to see their product / service for this problem.

-------------------

Steve

Owner, 1990 Thunderbird SC, white w/ gray cloth
S_Mazza is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-02-2003, 02:29 AM
 
Join Date: May 2003
Posts: 47
I'm sure glad my bore wasnt hashed after 400 miles of driving with a broken 1-2 Lower spring.

Guess I was one of the lucky ones.

Thanks for the link for the "Just incase"
Rotordemon20B is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome