Tranny pooched? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-11-2003, 02:17 PM Thread Starter
 
Join Date: Jul 2002
Posts: 376
Tranny pooched?

I started to do my engine swap today. First order of business is to drain the Mercon V out of the tranny using A-Train's suggested method of connecting a hose to the top Rad fitting. So I do that, start the motor up. WTF, no fluid! So I rev the engine to about 2000 RPM and fluid comes dribbling out, and it's really dark and wierd looking. I ran the engine for about 2 minutes and got about 2 cups of fluid. I figure there's something seriously wrong so I stop. I reconnect the host to the rad (I have a tranny cooler), and start the car and check the fluid level in the tranny. It shows about right on the dip stick and the color doesn't look that bad. I'm worried about the lack of pressure. WHen I did the J-mod, draining the fluid using this method took just a few minutes. Right now the only problem I've got with the tranny is that it's in converter lockup mode all the time.
Any ideas as to what could cause the symptoms I've described?
bigbird is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-11-2003, 10:45 PM
PostWhore
 
Join Date: Aug 2003
Location: Preferred Location
Posts: 1,064
This is just a guess, but when I recently got my trans rebuilt, the guy told me that he bypassed the radiator and hooked up the lines directly to the new cooler because he says those radiators become clogged up over time. He ensured me it was better this way. Don't know if that's related to your problem though.

I come from a dusty place.
4point6r0x0rz is offline  
post #3 of 3 (permalink) Old 10-12-2003, 10:09 AM Thread Starter
 
Join Date: Jul 2002
Posts: 376
Sounds like it might be. I think that the clutch material is being worn off in the t/c and that's why the fluid looks so dark. My mechanic friend thinks that the filter is plugged. I'm getting the tranny rebuilt next week. This shop has a dyno where they can test after they're done. My buddy's gonna complete the engine swap once the transmission comes back. It's gonna cost me about 1200.00 CDN for labor and about 650.00 for the rebuild. The tranny shop will maintain the j-mods. That blows the budget, so I will have to postpone the body/paint renew.
bigbird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome