Tranny Review - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-01-2004, 09:29 PM Thread Starter
5th Gear Poster
 
Join Date: Jul 2002
Location: Katy, TX
Age: 58
Posts: 453
Tranny Review

As some may or may not know Ross House built me a modified 4r70w tranny about 60,000 miles ago. This was one of the first built from the tranny 101 article. The lockup clutch on the convertor was starting to go after 7 years so I had Ross go through the tranny while it was out. All and all it was in good shape considering the abuse. All the bands were in good shape accept for 3rd gear it had some hot spots. Since some of the technology has changed from the original article was written he upgraded some parts. He also repaired the howl in the rearend replacing the carrier bearing and a bunch of other stuff. If you need a rebuild in Texas he is the man. He had it out rebuilt in a day. He went over every thing post mortum and all the stuff he replaced. It rides like a brand new car.

mazda6 Sport- 06
100hp worth of Stickers coming soon
Blake-vortech is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome