trans problem - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-10-2004, 08:07 PM Thread Starter
Newbie
 
Join Date: Mar 2004
Location: Marysville,MI
Posts: 5
trans problem

hi i installed the AOD-HP kit in my trans and now when i drive it it seems to slip when taking off and when in regular drive it will go to 4200 rpms no matter what and then shift. then when in od it seems to shift sort of ok. it almost won't kick down out of 3rd. do i need to readjust the tv cable even if i didn't touch or even look at it. now if i didn't do any damage to the trans i have been even thinking of a full manual valvebody. thanks
rdj59 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-11-2004, 03:07 PM Thread Starter
Newbie
 
Join Date: Mar 2004
Location: Marysville,MI
Posts: 5
anyone
rdj59 is offline  
post #3 of 3 (permalink) Old 03-14-2004, 12:11 PM
3rd Gear Chirper
 
hotbird's Avatar
 
Join Date: Dec 2002
Location: Englewood FL
Age: 34
Posts: 2,399
Um, the AOD-HP kit required you to remove the valvebody, correct? Did you properly torque the bolts back to specs when you reinstalled it? And have you gone back into the tranny a few thousand miles after the install and re-torqued the VB bolts? I mis-torqued mine and had it would only hold third gear for about .5 second and not at all when at WOT, it just went 1-2-4. Also, it would neutral out on takeoff. Retightening the VB bolts cured it.
hotbird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome