New Dennis R tranny, I have a leak? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-29-2004, 09:09 AM Thread Starter
PostWhore
 
Join Date: Jul 2002
Location: Sun city, ca
Posts: 1,278
New Dennis R tranny, I have a leak?

The tranny makes the car a whole 3 sec faster on the 0-60. So I am very happy with it. But it leaks every time I drive it. About a spot the size of a hand ball. But only if the car has a chance to warm up. Never when I just cycle through the gears sitting in my drive way. I check the tranny leval and keep it full. So mechanical failure isn't to likely. But that damn fluid makes a mess and it isn't cheap for MER V. Does any one know what seals or "o" rings need to be new when performing a tranny swap? Or what has leaked when doing the same swap? Thanks...Eric

2011 Kia Sorrento
1996 T-bird
*SOLD* 2007 Suzuki M50

Looking for a new ride!
funderbird is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-29-2004, 10:46 AM
Seasoned Veteran Poster
 
95BLKLSC's Avatar
 
Join Date: Apr 2003
Location: Westport, MA
Posts: 974
wow 3 second faster on 0-60? how bad was yoru trannie before??

95 LSC- Mods: 2.5 dual exhaust, 3.73s, 17x9 cobra R Rims, SCT dyno tune, MM driveshaft, 249 rwhp/ 268 ft lb tq
97 Base- Mods: Forged motor, Eaton m112, 2.76 pully, too many mods to list..........
My Car Domain Page
95BLKLSC is offline  
post #3 of 4 (permalink) Old 03-29-2004, 04:38 PM
6th Gear Poster
 
Ashish's Avatar
 
Join Date: Jul 2002
Location: Tampa, FL
Age: 35
Posts: 615
Send a message via AIM to Ashish
I'll just throw some stuff out there. There is a seal for your drive shaft, that could have been ruined when putting the drive shaft in. Also if you put a new TC in you should change the seal behind converter. Thats all I can do for you, put the tranny is a complete rebuild so I don't know why a seal would leak.

1997 Birdie, its the good one. Limited Edition Sport Sold
9/6/03-9/7/03-J mod & Mark VIII TC 12/26/03-Apten Chip & 03 GT MAF 3/11/04-3/14/04-PI Cams & PI Intake 8/19/04-FRPP 3.73 Diffy2/26/05-SCT chip (burned by Ken B.)

1998 Z28 M6 5.7 LS1
Ashish is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-30-2004, 10:17 AM Thread Starter
PostWhore
 
Join Date: Jul 2002
Location: Sun city, ca
Posts: 1,278
How bad was it before? Well, put it in terms that I understood. It felt like I had a 3000 stale on my converter. When I read the troubleshooting artical about tranny problem. My old tranny had every problem that it listed. Not to mention it was so hot that if I places my leg agianst the hump, I could feel the heat radiating off the carpet. It was bad...Eric

P.S. The leak I had was from my fill tube. The o ring had severed and was not even there. I still have one drop about the size of a quarter. But I figure I will eventually fine the problem...

2011 Kia Sorrento
1996 T-bird
*SOLD* 2007 Suzuki M50

Looking for a new ride!
funderbird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome