Bad TC I think - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 04-07-2004, 04:29 PM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
Bad TC I think

Right,

When I accelerate hard off the line, sometimes my car will take off slower than a snail. Though the engine sounds like its winning a race...

Rpm is high and Im berly moving.... say 15 20 25 mph, then when the car gets to a certain mph it feels lioke it catches, and second gear chimes in and off we goooo! but I have been reading and Was thinking that the TC is just spinning to much? not working right?


Any thoughts?
Thanks

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-07-2004, 06:42 PM
6th Gear Poster
 
MadRussian's Avatar
 
Join Date: Sep 2002
Location: Chesterfield, MO
Age: 35
Posts: 632
Send a message via AIM to MadRussian Send a message via MSN to MadRussian Send a message via Yahoo to MadRussian
Is your check engine on or OD light flashing?

Does it do it in manual 1 and manual 2?

-Andrey

96 LX 4.6L
13.215 @ 103.09
MadRussian is offline  
post #3 of 10 (permalink) Old 04-08-2004, 12:26 AM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
No the engine light is not on, and the OD light is fine. but I will check if it does it in manual...

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 04-08-2004, 10:30 PM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
This problem Is only really noticeable when The car is cold.....


I checked fluid, and it looks to be ok. Wouldnt a lack of fluid in the tranny be a cause? And also, would I put fluid into the tranny through the dipstick hole?


Thanks

Garrett

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
post #5 of 10 (permalink) Old 04-08-2004, 10:38 PM
6th Gear Poster
 
MadRussian's Avatar
 
Join Date: Sep 2002
Location: Chesterfield, MO
Age: 35
Posts: 632
Send a message via AIM to MadRussian Send a message via MSN to MadRussian Send a message via Yahoo to MadRussian
Again, does it do it in manual 1 and manual 2?

What color is the fluid, and how does it smell? When was the last time the fluid was changed? Do you know if you have Dexron III or Mercon V?

If you owned the car for some time, was there "shudder" when going into 3rd and 4th gears?

-Andrey

96 LX 4.6L
13.215 @ 103.09
MadRussian is offline  
post #6 of 10 (permalink) Old 04-09-2004, 04:15 PM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
It does not do it on 1 or 2 manual shifts. And no... I've had the car for about two weeks now, It was my fathers, Taken good care...

I have no I dea what type of fluid is in the car, (If I were to bet I would Say dextron) The fluid color is Red, and seems normal, no burt smell... (If that is what you are looking for)


The car just rolled to 131,000 today. I know my year of tranny isnt the stongest... But If I were to have to fix the tranny in some way, would you suggest a newer model of tranny? Or could I update the inerds cheaper than buying a new one?


Thanks

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
post #7 of 10 (permalink) Old 04-09-2004, 05:26 PM
Moderator
Moderator
 
JustinH's Avatar
 
Join Date: Jul 2002
Location: Austin, TX
Age: 37
Posts: 8,239
Send a message via AIM to JustinH
is it slipping into neutral?
JustinH is offline  
post #8 of 10 (permalink) Old 04-09-2004, 05:49 PM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
no,

It has pull... just high revs and goes slow.... Like the TC isnt locking...



MG

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
post #9 of 10 (permalink) Old 04-09-2004, 07:12 PM
6th Gear Poster
 
MadRussian's Avatar
 
Join Date: Sep 2002
Location: Chesterfield, MO
Age: 35
Posts: 632
Send a message via AIM to MadRussian Send a message via MSN to MadRussian Send a message via Yahoo to MadRussian
TC not locking would cause more "pull" at high revs, your car would rev higher but would not go slow; besides in 1st and 2nd the TC does not lock.

-Andrey

96 LX 4.6L
13.215 @ 103.09
MadRussian is offline  
post #10 of 10 (permalink) Old 04-09-2004, 07:26 PM Thread Starter
PostWhore
 
MadGoat's Avatar
 
Join Date: Apr 2004
Location: Tucson, AZ
Age: 34
Posts: 1,072
Send a message via AIM to MadGoat Send a message via MSN to MadGoat
hummm good to know, Could this be a engine prob?


MG


BTW: this is my first Auto I have owned, trying my best to learn as much as I can quickly

MadGoat's Birds
94 Thunderbird LX 4.6L PI
03 Aluminum PI Engine, J-Mod, Aluminum one piece drive shaft, 3.27's, 2.5" to single 3" custom MagnaFlow exhaust, 07 17x8 Bullit Wheels
97 Thunderbird LX 4.6L V8
RIP
MadGoat is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome