Transmission troubles - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-13-2004, 08:48 PM Thread Starter
 
Join Date: Feb 2004
Posts: 13
Transmission troubles

I am looking for help on my AOD, I have a 90 Lincoln Mark VII, with an AOD that has all Art Carr components, and also a manual valvebody, TCI 3600 Stall lock up torque converter. It shifts fine in 1st & 2nd, but in 3rd and 4th is seems like it doesn't exist. could it be that the torque converter is not engaging for 3rd and 4th??? It runs great cold but after 5 -10 mins, it acts like it is slipping all the time. It also is a fresh rebuild
NoLmtsLncln is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-14-2004, 06:24 PM
Seasoned PostWhore
 
Silver95Bird's Avatar
 
Join Date: Aug 2002
Location: Gouldsboro, PA
Age: 36
Posts: 3,178
No 3rd and 4th gear (ie. neutralling) would lead me to suspect things like:

Possible VB problems
Direct clutch seals not working
Direct clutch frictions worn
Splines of the Direct Clutch drum/Input shaft/Torque converter

The input shaft is splined directly between the drum and TC, so in 3rd and 4th gear it's always locked up. High HP cars have been known to twist or break input shafts, while lower HP cars will see more seals/frictions wearing out. The aftermarket VB is a giant ? to me, a sticking valve in there could possibly cause the problem. Get it looked at soon though, hopefully its something simple.

96 Mustang GT 5spd. w/ 248A Option (GTS). Stock for now until I get the Roush on.

97 Thunderbird 4.6L LX /w Sport Package
24k B&M Cooler, 1" lowered, Steeda UD Pulleys, Dynomax cat-back, J-mod, 3.73's, PI intake, PI cams, 03 GT MAF/Tube, SCT tuned - Gone but not forgotten.
MAMN12 Drag Racing Team [email protected] In need of updated times.
Silver95Bird is offline  
post #3 of 3 (permalink) Old 05-14-2004, 06:42 PM Thread Starter
 
Join Date: Feb 2004
Posts: 13
I don't know what I am pushing for HP or TQ, but i have a 306, with a 9.9:1 compression, Edelbrock RPM heads, and RPM intake,#24lb injectors, 75m MAF and 255lph fuel pump and a A-trim vortech supercharger and a free flowing exhaust. with 3.73's on the rear
NoLmtsLncln is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome