Trans skip - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 05-20-2004, 12:16 PM Thread Starter
1st Gear Poster
 
Join Date: May 2004
Location: Virginia
Posts: 36
Trans skip

92 5.0 My trans skips when I am in overdrive going up a hill in a low rpm. This is the only time it does this. Anyone know anything about this?
Tim925.0 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-23-2004, 07:24 PM
3rd Gear Chirper
 
hotbird's Avatar
 
Join Date: Dec 2002
Location: Englewood FL
Age: 34
Posts: 2,399
What do you mean by skips? Does it go into neutral or into another gear, or just shudder?
hotbird is offline  
post #3 of 6 (permalink) Old 05-23-2004, 10:52 PM Thread Starter
1st Gear Poster
 
Join Date: May 2004
Location: Virginia
Posts: 36
It does not go into another gear just shutters.
Tim925.0 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 05-25-2004, 03:19 PM
Johnny Bling Bling
 
93 lx's Avatar
 
Join Date: Jul 2002
Location: Lunenburg, MA
Age: 41
Posts: 3,811
Send a message via AIM to 93 lx
don't know your mileage, but i would suggest draining the whole tranny, changing the filter, refill(about 12-13 qts) using mercon V and ford friction modifier, and i bet that will help. mervon V is safe in the aod...i have been using it for awhile, and others have too with no complications. just make sure you get ALL of the merc. III out first.

2003 Ford Expedition: 5.4L, harley supercharger, 2.93 upper pulley, 4lb lower pulley, c&l plenum, jlp cai, LFP SBTB, FTSP, Magnaflow 3" catback, Eclipse AVN-5510, white face gauges, cobalt c2 boost gauge, ddm hid's, 379 rwhp, 465 rwtq sold 11/3/12

2009 Ford Flex Limited AWD
93 lx is offline  
post #5 of 6 (permalink) Old 05-25-2004, 03:52 PM Thread Starter
1st Gear Poster
 
Join Date: May 2004
Location: Virginia
Posts: 36
How do you make sure you get all of the merc. III out? My car has 86K it had 75K when I got it two years ago. I have never changed the fluid.
Tim925.0 is offline  
post #6 of 6 (permalink) Old 05-25-2004, 04:03 PM
Johnny Bling Bling
 
93 lx's Avatar
 
Join Date: Jul 2002
Location: Lunenburg, MA
Age: 41
Posts: 3,811
Send a message via AIM to 93 lx
drop the pan. then pull t.c. plug and let that drain. that should get most of it. to do it completely, you can drop the valve body as well, as that hides some too. just a matter of about 10 screws. you can probably get away without doing the vb though, if you don't want to get that involved.

2003 Ford Expedition: 5.4L, harley supercharger, 2.93 upper pulley, 4lb lower pulley, c&l plenum, jlp cai, LFP SBTB, FTSP, Magnaflow 3" catback, Eclipse AVN-5510, white face gauges, cobalt c2 boost gauge, ddm hid's, 379 rwhp, 465 rwtq sold 11/3/12

2009 Ford Flex Limited AWD
93 lx is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome