problems shifting between 2 and 3 - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-10-2005, 08:45 PM Thread Starter
1st Gear Poster
 
Join Date: Feb 2004
Location: New York
Posts: 59
problems shifting between 2 and 3

i own a 94 cougar and have already replaced the transmission. i am still having a problem once in a while. while shifting between 2nd and 3rd or 3rd to overdrive the tranny is slipping into neutral. the tranny guy said it might be the MAP sensor, however my machanic says it doesnt have a MAP sensor. so he changed the airflow sensor. since then the problem continues to occur. this seems to happen most often while traveling up hill during moderate acceleration. anybody have any ideas?
medicalmike is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-11-2005, 12:05 AM
PostWhore
 
Join Date: Dec 2004
Location: Newark, Delaware
Age: 58
Posts: 1,362
Cool

There were several problems with these trans.. Ask the shop to make sure that they filled it with Mercon V fluid. Any other will cause slipping, and other various issues. Also, Ford had a problem with the electronic range senser for which there is a replacement. It is on the trans.. These are only the minor issues and I hope this helps!!
Uncaged 94 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome