Shift kit Problem - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 07-10-2006, 09:26 PM Thread Starter
 
Join Date: Mar 2006
Posts: 102
Shift kit Problem

I installed a transgo shift kit on my aod trans and during the test drive i found out that it now shudders coming off of a stop with anything but light throttle and also when i floored it the rpm didnt jump up quickly like usual and slowly climbed until it finally jumped after a second or two and felt like it was slipping. Im going to call trans go tommorrow but for now any advice would help.
Birddude93LX is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-10-2006, 09:28 PM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
Sounds like low fluid or a missing filter gasket to me.
Alan

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
post #3 of 4 (permalink) Old 07-10-2006, 09:45 PM Thread Starter
 
Join Date: Mar 2006
Posts: 102
I was thinking low fluid too but the fluid seems to be full but i also did install a trans cooler with the shift kit so that might have some affect. I also remmeber installing the filter gasket but im thinking its a fluid problem
Birddude93LX is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 07-10-2006, 11:43 PM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
Those gaskets come out of place very easily.

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome