code 654 - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 09-21-2006, 01:36 PM Thread Starter
1st Gear Poster
 
Join Date: Jun 2005
Location: Home
Age: 34
Posts: 26
code 654

My aode has been giving me troubles about going into neutral, and it gets rough when slowing down. (shaking)

Replaced the mlps, mlps wire and its got good, full fluid.

I checked the codes the other day and it gave me 654, which is
Transmission Range sensor not indicating "PARK" during KOEO self-test.

What could this be?
mustangless is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-21-2006, 02:03 PM
6th Gear Poster
 
wether's Avatar
 
Join Date: Feb 2004
Location: Tomball, TX
Age: 42
Posts: 585
Send a message via AIM to wether
I have posted the Diagnostic routine at http://www.guardcows.com/ford in the appropriate directory. You will want to look at the file named 95_MLPS.pdf for reference. It also mentions something about needing a special tool. For more information this CD can be downloaded from http://www.fordcds.com

(I assumed it was the mustang in your profile )

Currently In the Short Bus Garage:
2 - '94 T-bird LX's 4.6L (one with 300,000+ miles and one with 200,000+ miles)
1 - '97 Mark VIII LSC - INTECH V8 (120,000+ miles)
1 - '97 F150 XLT 4x4 Flareside, 4.6L (130,000+ miles) - Currently being dismantled and rebuilt with upgrades!
1 - '00 Mustang GT (likes to accelerate with the brake on!), 4.6L (60,000+ miles - only comes out when I need to get somewhere fast.)

oh yeah, and they all have 4R70W's
wether is offline  
post #3 of 3 (permalink) Old 09-22-2006, 10:23 PM Thread Starter
1st Gear Poster
 
Join Date: Jun 2005
Location: Home
Age: 34
Posts: 26
Okay, I took the pcm out and probed the pins on the harness. Got the following results. 30 and 37-80.8 ohms, 30 and 57-92.5 ohms, 37 and 57-21.1 ohms, 40 and 60- it showed some numbers momentarly, 30 and 40-102 ohms, 30 and 60-open, 30 and 46-open, 30 and ground-showed numbers momentarly.

ANy ideas on what to do next??

The pcm and TR sensor has both been replaced also.

Last edited by mustangless; 09-23-2006 at 06:32 PM.
mustangless is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome