Overheating? Darrin or Allan -- need your help? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-01-2006, 09:53 AM Thread Starter
 
Join Date: Sep 2004
Posts: 67
Overheating? Darrin or Allan -- need your help?

Need help guys ---

Recently installed a lowmile tranny (had 18K on it as per recycler) in my car. It did look brand new when it arrived. Filled it with Mercon V and new filter and have been driving it. Shifts are smooth and no obvious problems in the beginning.

The more I drive the car, it seems that the engine is running harder and harder (higher RPMS) -- this was also proven that i was burning alot more gas as time went on. After about 5K on the new installed tranny, I checked the dip stick and mercon V has slightly changed color from light pink and there is the distinct burn tranny fluid smell which is not yet strong I can smell a slight burn smell to it

Dropped the tranny pan and the magnet has lots of clutch material sticking to it -- I was not expecting to see that much after only driving 5K on tranny. (pan and magner was cleaned before filling the tranny with fresh mercon V)

Was the tranny pooched to begin with or what could be causing this obvious overheating of the tranny fluid/ tranny. No falshing O/D lights etc -- no codes either? Sticky valve body? Checked the lines and cooler and no obstructions there either -- definately a tranny related issue I have got

NOTE: Shifts are still smooth but I can still feel the engine is running alot harder than it should

If it is sticky valve body, how to clean / repair it?

Thanks guys for all the help .....

NOTE: Car is a daily driver and I don't drive hard at all - No WOT or anything like that
tutuluke is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-01-2006, 12:12 PM
Converter Guy
 
dirtyd0g's Avatar
 
Join Date: Jul 2004
Location: batavia,oh
Age: 42
Posts: 6,617
Send a message via Yahoo to dirtyd0g
Did you flush the cooler prior to install?
Alan

DirtyDog Performance.Com
Proud sponsor of the SC/XR7 Shootout and Joel Bender Memorial Nats

Please do not send me messages on forums they are too hard to keep up with and I don't check in very often anymore call me at 513 898-1580 or email me alan at dirtydogperformance.com
dirtyd0g is offline  
post #3 of 3 (permalink) Old 12-01-2006, 12:19 PM Thread Starter
 
Join Date: Sep 2004
Posts: 67
No I didn't flush the cooler as I didn't feel that there was a need for it -- my old tranny didn't go bad -- it was running fine but had alot of miles on it so I decided to change it before it quit on me on one of my trips.

The fluid in the old tranny was not burnt at all.
tutuluke is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome