Anyone replaced their "window run?" - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-07-2005, 09:18 PM Thread Starter
Amateur Expert
 
Embalmer's Avatar
 
Join Date: Jul 2002
Location: Amboy, Illinois
Age: 47
Posts: 1,662
Send a message via AIM to Embalmer
Anyone replaced their "window run?"



The strip that goes from the mirror up the window and down to the base of the window on my car is cracked and rusting. Has anyone replaced these and is it hard to do?

2007 Ford Mustang GT Premium - SOLD March 2014.
2013 Ford Taurus SHO (TUXESHO) Tuxedo Black Bone stock for now.
Embalmer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-07-2005, 11:50 PM
6th Gear Poster
 
Join Date: Mar 2004
Location: NC
Age: 38
Posts: 583
It's not too bad.. but you'll have to take the door cover off on the inside to get to the bolt that holds it in at the front of the door. I poked through the protective sheet to take it out.. or you can remove it. Might help to take your speaker out to get a hand in there too. I can't remember at this moment, but I don't think the rear has a bolt... It can be kinda tricky to get out.. I had to fight with mine a couple minutes cause I didn't want to bust it. Just make sure you got it seated really good and it has tracked back onto the window before you put everything back in.

a black car.
Sophosis is offline  
post #3 of 3 (permalink) Old 03-08-2005, 02:22 AM
Rob
Seasoned PostWhore
 
Rob's Avatar
 
Join Date: Jul 2002
Location: Hubbard, TX
Age: 37
Posts: 3,902
Send a message via AIM to Rob
I took mine out when I painted the car. It was freaking easy. After you have the door panel off there are 2 nuts holding the glass to the regulator. Then 2 nuts/bolts holding that trim thing in. You push down on it and slip it out.
-Rob

-Rob
RIP '94 Amber Fire Pearl Metallic Thunderbird on Bullitts [email protected]
96 Sport '02 Explorer PI with ported heads, 90MM LMAF, DirtyDog Marauder TC, Lasota tune, Jmod, Magnaflow mid-mount with X, no cats. Urethane drivers motor mount. HIDs!
Rob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome