Blinkers dont work. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-25-2005, 07:01 PM Thread Starter
3rd Gear Poster
 
Join Date: Jul 2002
Location: St. Louis, MO
Age: 36
Posts: 159
Blinkers dont work.

I replaced the multi-fuction switch twice and the blinkers still dont work, but the harzards work. The fuse isnt blown, what could the problem be?

-91 XR7

-92 Mercury Cougar
3.8 N/A for now!

-88 LX Mustang 5spd
GT40P Heads, FMS Ceramic Headers, Mac O/R H-pipe, Flowmasters, U/D Pullies, Ported stock intake, Steeda Tri-Ax shifter
Fastcat is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-25-2005, 07:18 PM
Trumpeter Extraordinaire
 
IronChopz's Avatar
 
Join Date: Jul 2002
Location: Saturn (or SE Michigan)
Age: 57
Posts: 2,916
It may be a faulty flasher module. Check the fuse panel under the dashboard for a larger, round module. That's the flasher module.
IronChopz is offline  
post #3 of 5 (permalink) Old 04-26-2005, 11:09 AM
6th Gear Poster
 
95tbirdv8's Avatar
 
Join Date: Nov 2003
Location: Houston
Age: 32
Posts: 600
what if on my car its backwards, the blinkers work but the hazardous lights dont, could it be the same thing?

95 mark 8 lsc
95 tbird v8
90 mustang gt
92 mustang gt
07 silverado v8
08 yamaha r6
95tbirdv8 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-26-2005, 12:11 PM
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
its the switch mfs i think its called? dont get me wrong is that thing the you push to activiate the flashers.. I had ford fix it when I was in a bind without time.. oh was that pricey!

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #5 of 5 (permalink) Old 04-26-2005, 09:10 PM
 
Join Date: May 2003
Posts: 2,230
I am almost positive that it would be the flasher. They run a whopping $5.00 or so, its worth the shot.
lightevergreenfrost is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome