Reapplying badges after paint - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 05-01-2006, 08:37 PM Thread Starter
Amateur Expert
 
Embalmer's Avatar
 
Join Date: Jul 2002
Location: Amboy, Illinois
Age: 47
Posts: 1,662
Send a message via AIM to Embalmer
Reapplying badges after paint

I need to put my "Thunderbird LX" and "Ford" badges back on the decklid after a paint job. These are stuck using some sort of black foam adhesive? Where can I get the stuff and how the heck do I get it to fit on the back of the Thunderbird LX script?

2007 Ford Mustang GT Premium - SOLD March 2014.
2013 Ford Taurus SHO (TUXESHO) Tuxedo Black Bone stock for now.
Embalmer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-01-2006, 08:48 PM
 
Join Date: Jun 2005
Posts: 850
they sell some stuff at pepboys called 3M Foam tape for trim and emblems or something and it seemed to work pretty good when I put my 4.6 badges back on.
post #3 of 5 (permalink) Old 05-03-2006, 10:07 PM
Seasoned PostWhore
 
8ate8's Avatar
 
Join Date: Aug 2002
Location: South Amboy, NJ
Age: 37
Posts: 2,075
Send a message via AIM to 8ate8
Shoulda just filled the holes when they painted and left the badges off

Jersey Rice
NJ Thunderbird & Cougar Club
Sold '96 Thunderbird LX 3.8l :: Cardomain Page
'93 Thunderbird SC 3.8l - 12 second car. 14 second driver.
'05 Toyota X-Runner
8ate8 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 05-04-2006, 12:23 AM
Refrigerator Raider Hater
Moderator
 
GreenBird's Avatar
 
Join Date: Jul 2002
Location: Vermont
Age: 36
Posts: 11,719
I used 3M foam tape as well. Just roll it out, and cut as needed. Only costs a few bucks, and should be enough to do both emblems.




Matt "Looks Like Egon" Davis
96 Alpine Green V8
98 Audi A8 4.2Q in Racing Green Totalled
02 Audi A8L 4.2Q in Black

I buy my OEM Ford parts at 10% over dealer cost from Steve in White Bear Lake, MN.
You drive "like a man possessed"... by a woman!
GreenBird is offline  
post #5 of 5 (permalink) Old 05-05-2006, 08:45 PM
 
Join Date: Mar 2006
Posts: 451
I used a adhesive glue (just automotive clear glue), worked better then that double sided sticky tape crap.
LincolnLSC5pnt0 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome