My Poor LSC.... - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 06-09-2008, 08:04 AM Thread Starter
Seasoned PostWhore
 
Join Date: Jul 2002
Location: Cullman, AL
Age: 56
Posts: 7,758
Send a message via AIM to 94 Daily Driven 4.6L
Unhappy My Poor LSC....

Is friggin' falling apart!!!

Running great, but it's those "little things" that will piss you off.

About 9 montsh ago the blend door went bad (AGAIN), but it had stuck in the "no heat" mode, so it wasn't a problem during the summer with nice cold A/C.... Until I hit a bump pretty hard and now I have heat... and no A/C....

Then the cover for one of the power window switches falls off and lands in my seat…

Then the cover for the interior door light lands in my back seat floor board…

Then the passenger seat auto goes forward when I put something in the back seat like it should... But won't go back on it’s own or with the controls. So it's all the way forward. (broken wire)

All this happened ON SATURDAY!!!!!

I'm like WTF!!!

97 Lincoln Mark VIII LSC (Chip'd, 3.73 T/L... so far... )
97 Ford Aspire (Slow, but getting 36 mpg (f'n Ethenol!! )
84 F250 Dually w/6.9L Diesel (7.3L IDI pending)
73 Mercury Cougar Convertible w/351C 4V (Partially Restored)
69 F100 LWB w/460 Engine
76 Glastron Carlson 23' Jet Boat w/460 CJ Engine
94 Daily Driven 4.6L is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-09-2008, 09:03 AM
Braincoating! It's what all the cool kids have!

Administrator
 
tbirdbrain's Avatar
 
Join Date: Oct 2003
Location: South Florida
Posts: 2,725
Time to order the extra large crazy glue bottle and upgrade the AAA membership!

www.BRAINCOATING.com..... Powder & Ceramic Coating

WWW.PRESTONSBOOKS.BIZ..... Books at really great prices!
tbirdbrain is offline  
post #3 of 8 (permalink) Old 06-09-2008, 10:16 AM
$.25 poster
 
AlpineBird's Avatar
 
Join Date: Nov 2003
Location: South Jerz
Age: 32
Posts: 1,900
Send a message via AIM to AlpineBird
Quote:
Originally Posted by 94 Daily Driven 4.6L View Post
About 9 montsh ago the blend door went bad (AGAIN), but it had stuck in the "no heat" mode, so it wasn't a problem during the summer with nice cold A/C.... Until I hit a bump pretty hard and now I have heat... and no A/C....
Welcome to my world. I deal with the same exact problem in the T-Bird. Luckily right now I have AC....but I know that bump in the road that knocks it back to heat will eventually come lol.

'96 Alpine Bird 281ci
- Clear Corners
- DynoMax Cat-Back
- Purchased with 36,000 miles, now at 101k
- No mods planned untill it's DD life is over

1998 5.9 Limited Grand Cherokee
- Flowmaster Exhaust
- AEM Brute Force Intake
- Mopar Performance ECU

- 275hp-395ft/lbs at the crank (est.) Track results in the spring!!!
AlpineBird is offline  
post #4 of 8 (permalink) Old 06-09-2008, 11:09 AM
Seasoned PostWhore
 
Join Date: May 2003
Location: Tinton Falls, NJ
Age: 36
Posts: 7,413
Garage
Send a message via AIM to MadMikeyL
I wish mine would bump over to heat. Then I wouldn't have to pull the dash at the end of the summer. I never use AC anyway, so it really annoys me that it is stuck on cold.

For the window switch, is there a way to re-attach that top piece? Mine fell off too, and is sitting in my center console until I get around to trying to fix it.

-91 Cougar LS, coming soon, complete overhaul with a 427" Windsor.
-90 XR7 5-speed black on black w/sunroof, MP2, coated rotors, double intercooler, 15%OD, ported heads, comp stage 1 cam, 85mm TB, 90MM LMAF, 80# injectors, and ported big valve heads
-98 Mark VIII LSC, Procharger P600b, TR3650 swap and 3.73s.
-90 SC Automatic rustbucket winter beater
-97 Tbird Sport 4.6 Nice weather daily driver
-"Your buddy Mike is INSANE!" -ClintD's dad
MadMikeyL is offline  
post #5 of 8 (permalink) Old 06-09-2008, 11:19 AM Thread Starter
Seasoned PostWhore
 
Join Date: Jul 2002
Location: Cullman, AL
Age: 56
Posts: 7,758
Send a message via AIM to 94 Daily Driven 4.6L
Quote:
Originally Posted by MadMikeyL View Post
For the window switch, is there a way to re-attach that top piece? Mine fell off too, and is sitting in my center console until I get around to trying to fix it.
Yes there is... This was the last of the three of mine to have fallen off!!!

A small drop of clear RTV right in the middle seems to work fine. Probably any RTV would work, just don't cover up the LED. (At least that has worked for me so far. My other two haven't fallen off again... yet).

Take note: The cover is not symmetrical. IIRC, one end is slightly convex, and the other end is slightly concave. You have to make sure you get it alighted right or it won't hold the chrome surround properly.

Hope that helps.

97 Lincoln Mark VIII LSC (Chip'd, 3.73 T/L... so far... )
97 Ford Aspire (Slow, but getting 36 mpg (f'n Ethenol!! )
84 F250 Dually w/6.9L Diesel (7.3L IDI pending)
73 Mercury Cougar Convertible w/351C 4V (Partially Restored)
69 F100 LWB w/460 Engine
76 Glastron Carlson 23' Jet Boat w/460 CJ Engine
94 Daily Driven 4.6L is offline  
post #6 of 8 (permalink) Old 06-09-2008, 11:31 AM
Veteran Poster
 
EvilMooseofDoom's Avatar
 
Join Date: Mar 2004
Location: People's Republic of Oregon
Age: 47
Posts: 732
(cue sound of someone scratching the MK8 off of their vehicle shopping list...)

Yes, I hate my Lincoln. Ask me about it sometime.

My Drivetribe garbage:
https://drivetribe.com/u/ivrqNaWFWj_...SaGpcKvLTz6v9w

My LarryLand Automotive Facebook Page:
https://www.facebook.com/pages/Larry...61642343862942

My Scribd.com garbage: http://www.scribd.com/larry_vanzandt
EvilMooseofDoom is offline  
post #7 of 8 (permalink) Old 06-09-2008, 01:33 PM
Seasoned PostWhore
 
Join Date: May 2003
Location: Tinton Falls, NJ
Age: 36
Posts: 7,413
Garage
Send a message via AIM to MadMikeyL
Quote:
Originally Posted by EvilMooseofDoom View Post
(cue sound of someone scratching the MK8 off of their vehicle shopping list...)
Drive the car before you scratch it off your list. The ride is SO NICE! After about 2 days of driving the car, I decided every car that you care about the ride quality, should get an air-ride suspension.

For the switch, the chrome trim around it wasn't siting right on mine. I must have had it backwards. I'll fix that tonight. Thanks.

-91 Cougar LS, coming soon, complete overhaul with a 427" Windsor.
-90 XR7 5-speed black on black w/sunroof, MP2, coated rotors, double intercooler, 15%OD, ported heads, comp stage 1 cam, 85mm TB, 90MM LMAF, 80# injectors, and ported big valve heads
-98 Mark VIII LSC, Procharger P600b, TR3650 swap and 3.73s.
-90 SC Automatic rustbucket winter beater
-97 Tbird Sport 4.6 Nice weather daily driver
-"Your buddy Mike is INSANE!" -ClintD's dad
MadMikeyL is offline  
post #8 of 8 (permalink) Old 06-09-2008, 02:23 PM
PostWhore
 
Join Date: Aug 2002
Location: LA aka NW FL
Posts: 1,544
Time for some Alabama chrome....


"If it shouldn't move and does, use the duct tape."

Sometimes, we just need to remember what the rules of life really are:
You only need two tools: WD-40 and Duct Tape. If it doesn't move and should, use the WD-40. If it shouldn't move and does, use the duct tape.
doodaa is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome