87 ranger 2.9 running rough - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 03-01-2006, 04:39 PM Thread Starter
PostWhore
 
Join Date: Jul 2002
Location: GLENDORA CA
Age: 39
Posts: 1,119
87 ranger 2.9 running rough

I dont have a CEL but I ran the scan tool "KOEO Memory code" and got code 31 "EGR Valve position or exhaust pressure transducer sensor voltage low" What is this?..a new o2 sensor needed? I have pacesetter headers and I had to plug up the EGR if I remember correctly. Any ideas???
94ONAIR is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-02-2006, 12:36 PM
PostWhore
 
ZackG's Avatar
 
Join Date: Jul 2002
Location: SW PA
Age: 37
Posts: 1,798
Send a message via AIM to ZackG Send a message via Yahoo to ZackG
your ranger has an egr position sensor. its about $30 if i recall correctly. with you plugging the egr up, its probably throwing a code

97 Tbird 4.6
VT built block, fox lake PI heads
Vortech at XY psi
4.10's, KB boost a spark.
Yummy.
http://www.cardomain.com/ride/2147246
ZackG is offline  
post #3 of 3 (permalink) Old 03-02-2006, 05:27 PM Thread Starter
PostWhore
 
Join Date: Jul 2002
Location: GLENDORA CA
Age: 39
Posts: 1,119
Well today I changed the fuel filter, plug wires and still get a rough idle at Park and it wants to stall when in reverse at low speeds...when I put in in drive and just drive it....it seems fine. So I am out of ideas of what it could be..? I checked all vacum lines...
94ONAIR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome