swar bar end links and Addco heavy bar - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-24-2009, 12:25 PM Thread Starter
Newbie
 
Join Date: Sep 2005
Location: North West Chicago Il.
Age: 70
Posts: 18
swar bar end links and Addco heavy bar

Question about sway bar end links and heavy sway bar.
Did the full front end repair tokico springs & shocks and Addco 1 1/4 sway bar.
I put on new sway bar end links, UCA, LCA, strut mounts, everything.
I have cut and ground the shock mount bracket to clear the Addco sway bar. PITA
I have a rattle in the right front suspension that I think is a sway bar end link, (OEM straight design)
Is it possible to burn out an end link with the heavy duty sway bar?
I thought they would last a long time.
I do have the shorter angled links to install.
I'm hoping that the bar will be in another position to clear the shock mount bracket better.
Davetek is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 11-24-2009, 01:03 PM
3rd Gear Poster
 
Join Date: Oct 2002
Age: 39
Posts: 170
Quote:
Originally Posted by Davetek View Post
Question about sway bar end links and heavy sway bar.
Did the full front end repair tokico springs & shocks and Addco 1 1/4 sway bar.
I put on new sway bar end links, UCA, LCA, strut mounts, everything.
I have cut and ground the shock mount bracket to clear the Addco sway bar. PITA
I have a rattle in the right front suspension that I think is a sway bar end link, (OEM straight design)
Is it possible to burn out an end link with the heavy duty sway bar?
I thought they would last a long time.
I do have the shorter angled links to install.
I'm hoping that the bar will be in another position to clear the shock mount bracket better.
Look at the hole on the bar where the link mounts. Mine was too big and i had to weld a washer on the bar so the link stud did not bounce around in it. That could be your problem. Also look at the frame rails of the car and make sure you are not making contact with the bar there also. If so pry the lip of the frame rails to give you clearence. I was hoping they would have fixed this by now.
RICARDOA1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome