Rack Play - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-14-2011, 05:55 PM Thread Starter
6th Gear Poster
 
Bay_Bird93's Avatar
 
Join Date: Mar 2008
Location: Bay Area
Age: 32
Posts: 511
Rack Play

Yesterday, I replaced my inner/outer tie rods and lower control arms with motorcraft and moog parts. Went to get it aligned at work and noticed the new passenger side inner tie rod had some play. Double checked to make sure it was nice a tight, and found that the play is actually in the rack which attaches to the inner tie rod. Is my rack bad or is there a worn bushing or something causing this?

'97 Lincoln Mark Viii LSC - Stock
'93 Ford Thunderbird - Splitport & M5r2
'64 Chevrolet Impala SS - Stock
Bay_Bird93 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-14-2011, 07:27 PM
The Parts Guy
 
racecougar's Avatar
 
Join Date: Jul 2002
Location: Imperial, Missouri (near St. L
Age: 36
Posts: 7,265
Sounds like it's time to replace the rack.

Rod @ AzzKicker Cars
[email protected]
90 XR7-The Meth Addict-KB SC'd 5.0L DOHC Stroker
2004 Mustang GT-The Driver-Intake/Exhaust/3.73's
1995 F150 4x4-The Mud Toy-5.0L/4R70W/33's/Warn 8274 Winch
94 LX w/Splitport 3.8L from 2000 Mustang - SOLD
2 - 90 35th Anny Ed SC's
And a TON of parts cars!
racecougar is offline  
post #3 of 4 (permalink) Old 03-14-2011, 07:40 PM
3rd Gear Poster
 
slick59's Avatar
 
Join Date: Dec 2010
Location: Jerseyville, Illinois
Age: 47
Posts: 139
pita to rebuild the rack anyhow, just replace it. get a whole new unit with new inner tie rods.

I can explain it to you, but I can't understand it for you

Tim

1994 Cougar 3.8L Supercharged
1990 Tbird Supercoupe
slick59 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-18-2011, 06:47 PM Thread Starter
6th Gear Poster
 
Bay_Bird93's Avatar
 
Join Date: Mar 2008
Location: Bay Area
Age: 32
Posts: 511
Well that sucks. Ill just roll with it until the motor is out and put in a new rack then.

'97 Lincoln Mark Viii LSC - Stock
'93 Ford Thunderbird - Splitport & M5r2
'64 Chevrolet Impala SS - Stock
Bay_Bird93 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome