Reverse alignment issue - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 01-23-2012, 07:10 PM Thread Starter
Veteran Poster
 
ROLLINTHUNDER's Avatar
 
Join Date: Apr 2005
Location: New Haven, KY
Age: 42
Posts: 817
Reverse alignment issue

Havnt gotten it aligned since the Mark swap in which we swapped the entire front end over. When I start to back up you hera a clunk and the alignment changes drasticaly! The tires stick way out at the bottom and when you start turning backing out of the driveway its like the rear is dragging the front end out. The tires more or less start skipping. Start going forward and they straighten back up. I've put new sway bar links and upper control arms on it. I was thinking it could be the inside bushings on the lower control arms. Driving, the front end feels very swimmy and not responsive and safe at all.
ROLLINTHUNDER is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-23-2012, 07:12 PM
Seasoned PostWhore
Super Moderator
 
theterminator93's Avatar
 
Join Date: Jan 2009
Location: North Ridgeville, Ohio
Age: 31
Posts: 9,077
Garage
Strut rod bushings is my guess.

-Brandon
97 Laser Red Thunderbird LX 162k, Stage 2 4.6L 2v N/A | 300 BHP (255 RWHP, 290 RWTQ) | 13.95 @ 97.58 | Build details | Pics at the Lorain Assembly plant
98 Black Mark VIII 160k, stock daily driver
07 Redfire Fusion V6 SEL 178k, for the wife
Gone but not forgotten: 96 Mark VIII, 94 Cougar XR7, 93 Mark VIII

TCCoA's resident pilot since 2014
Once you have tasted flight, you will walk the world with your eyes turned skyward, for there you have been and there you long to return. -Leonardo da Vinci
theterminator93 is offline  
post #3 of 3 (permalink) Old 01-24-2012, 08:35 PM
Rob
Seasoned PostWhore
 
Rob's Avatar
 
Join Date: Jul 2002
Location: Hubbard, TX
Age: 37
Posts: 3,902
Send a message via AIM to Rob
Quote:
Originally Posted by theterminator93 View Post
Strut rod bushings is my guess.
Werd. Slack in the strut rod bushings will allow the control arm to move fore and aft.

-Rob
RIP '94 Amber Fire Pearl Metallic Thunderbird on Bullitts [email protected]
96 Sport '02 Explorer PI with ported heads, 90MM LMAF, DirtyDog Marauder TC, Lasota tune, Jmod, Magnaflow mid-mount with X, no cats. Urethane drivers motor mount. HIDs!
Rob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome