POP! and now the steering wheel isn't center - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 01-08-2015, 08:20 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Oklahoma City
Posts: 17
POP! and now the steering wheel isn't center

'96 XR7 4.6 with 164K on the clock.

I just did full rebuild of the front end a month or so back. All the control arms, bushings and shocks and springs. The steering wheel wasn't centered, so I paid a shop to do a front end realignment. The steering wheel got off a little again 10 to 20 degrees and I was figuring doing the rear shocks and rear control arm bushings and getting everything aligned again.

I heard a small pop the other day in the parking lot and didn't think anything about it. Today in reverse with the wheel cut hard, I heard a big pop and I thought some of my front end work had come apart or something. So I limped it home and noticed the steering wheel is like 90 degrees off now. The car doesn't pull and there is no noticeable slack between the steering wheel and the front wheel turning.

I'm thinking the rack and pinion is shot. So I'll do tie-rods, too.

Is something that happens?
J.P. is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-08-2015, 11:34 PM
PostWhore
 
CrystalPistol's Avatar
 
Join Date: Aug 2003
Location: Shenandoah Valley
Age: 65
Posts: 1,032
Sounds like the gears slipped a few cogs ..... something likely is cracked or broken or very worn.

A fine pair ... ... and whatever you do, Have a Safe Trip!
CrystalPistol is offline  
post #3 of 4 (permalink) Old 01-20-2015, 06:20 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Oklahoma City
Posts: 17
Well we replaced the rack and pinion, but that wasn't the problem. The local firestone store that I paid to do the alignment(instead of my dad's shop 50 miles away) didn't tighten the left side alignment cam nut. UGH. The aggravation of replacing the rack for no good reason. They did refund my money though.
J.P. is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-24-2015, 07:44 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Location: Oklahoma City
Posts: 17
Well it wasn't the rack and pinion. I swapped the rack and still had the odd pop or two. The problem was I paid the local Firestone to do the alignment after I have replaced just about everything in the front end. Those geniuses didn't smoke down the cam alignment nut and wasn't even hand tight. ugh. My dad's shop(40 miles from me) redid the alignment after I couldn't figure it out the popping. Firestone did refund my $85 though.
J.P. is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome