Creek/clunk sound from front right suspension. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 04-06-2015, 07:49 PM Thread Starter
2nd Gear Poster
 
Join Date: May 2011
Location: California
Posts: 99
Creak/clunk sound from front right suspension.

í97 T-Bird makes what I would describe as a mix between a Creaking or clunking sound. It sounds like itís coming from the front right suspension. Itís most noticed at low speeds when, breaking, going over mild bumps or turning the steering wheel when moving slowly. Turning the steering wheel when the car is stationary doesnít result in the sound.

Hereís the work that was done about 15k miles ago:
  • Strut rod bushings (left and right).
  • Lower Ball Joint (left and right).
  • Front inner tie rod ends (left and right).
The Upper Control Arm (left and right) was replaced about 25k miles ago.
The right side sway bar link was replaced about 70k miles ago.

Can anyone help me figure out what is causing this problem? How do diagnose etc?

Last edited by tweakit; 04-07-2015 at 01:42 AM. Reason: correct spelling
tweakit is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-06-2015, 08:07 PM
5th Gear Poster
 
steamer471's Avatar
 
Join Date: Jan 2010
Location: Charlotte N.C.
Age: 54
Posts: 404
70k only one sway bar link? I'd start by replacing both of those. Pretty cheap and easy.

1997 Mark 8 LSC

Former owner:
1996 Thunderbird lx 4.6
1994 Thunderbird lx 4.6
steamer471 is offline  
post #3 of 9 (permalink) Old 04-06-2015, 08:14 PM Thread Starter
2nd Gear Poster
 
Join Date: May 2011
Location: California
Posts: 99
The left side sway bar link was replaced 15k miles ago. I just didn't mention it since the noise is from the right side. Breaks were also done 15k miles ago. I'm not sure if there are any other front right suspension parts left that haven't been replaced but I'm not a suspension guy! I was expected the suspension was good to go for awhile.
tweakit is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 04-06-2015, 10:52 PM
Kind of slapped together
 
Join Date: Jan 2010
Location: Bossier City, LA
Age: 63
Posts: 4,851
Lay a weather eye on the sway bar bushings also.

RwP

Fuelly
RalphP is offline  
post #5 of 9 (permalink) Old 04-07-2015, 12:40 AM
PostWhore
 
1996Project-bird's Avatar
 
Join Date: Mar 2010
Location: NJ
Age: 28
Posts: 1,485
Depending on the parts you've used, they're all suspect. I have a creaking on mine as well and In the last year I've done the lower control arms, tie rod ends, sway bar links, bushings, upper control arms, shocks, shock mounts. You name it and it's been done. All moog or TRW, and now it's creaking.These cars just hate us.

I love my V8, but I'd love it more if all 8 cylinders worked. (they do now)

My T-bird is like George Jetson's wife, you try to give her a little money, she takes the whole wallet.
1996Project-bird is offline  
post #6 of 9 (permalink) Old 04-07-2015, 03:43 PM Thread Starter
2nd Gear Poster
 
Join Date: May 2011
Location: California
Posts: 99
Can the Lower Control Arm cause this kind of problem? I see there is a ball joint in the LCA.
The sway bar link has about 70k miles on it. Is there a test I can run to see if the sway bar link is at fault??
tweakit is offline  
post #7 of 9 (permalink) Old 04-07-2015, 08:39 PM
5th Gear Poster
 
steamer471's Avatar
 
Join Date: Jan 2010
Location: Charlotte N.C.
Age: 54
Posts: 404
Look at the boots, they usually tear and allow water in, if they're torn they're toast. Also noises under these cars travel, check your rear links, i've had rear ones go and it sounded like the front. There's a sticky on this forum for clunking under your front end, it's good reading.

1997 Mark 8 LSC

Former owner:
1996 Thunderbird lx 4.6
1994 Thunderbird lx 4.6
steamer471 is offline  
post #8 of 9 (permalink) Old 04-08-2015, 12:17 AM Thread Starter
2nd Gear Poster
 
Join Date: May 2011
Location: California
Posts: 99
I took a look at the sticky. Lots of good information there. Thanks!
tweakit is offline  
post #9 of 9 (permalink) Old 04-08-2015, 11:14 AM
PostWhore
 
dmw_4814's Avatar
 
Join Date: Apr 2009
Location: Phoenix, AZ
Age: 56
Posts: 1,164
Send a message via Yahoo to dmw_4814
When I purchased my 1997 T-Bird, I was able to negotiate a (significantly) lower price than what the seller was originally asking due to a HORRENDOUS knocking/banging sound the front suspension was making while I was driving the car, especially over bumps. We thought there was a serious problem with the front suspension.

It turned out to be only severely worn front sway bar end-links. Worst noises from a suspension I've ever heard! I replaced them (with Moog) almost 65,000 miles ago, and never had a single problem since. I would suspect them, or one or more of your ball joints.

Dennis
dmw_4814 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome