strut noise - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-04-2016, 09:02 AM Thread Starter
Seasoned PostWhore
 
coggonobrien's Avatar
 
Join Date: Jan 2006
Location: Coggon, Iowa
Age: 35
Posts: 2,008
Send a message via AIM to coggonobrien Send a message via MSN to coggonobrien Send a message via Yahoo to coggonobrien
strut noise

i'm getting noise from my front end which I assume is the strut mounts as everything else is new. The struts really don't have many miles, maybe 25000-30000, any chance I could just tighten them and be done?
coggonobrien is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-04-2016, 11:34 PM
Kind of slapped together
 
Join Date: Jan 2010
Location: Bossier City, LA
Age: 63
Posts: 4,855
I would check it carefully - something could be loose, something could be the wrong part (non-Ford front strut rod bushings), could be something totally unrelated.

Don't assume anything!

RwP

Fuelly
RalphP is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome