Power steering pump whine. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-15-2017, 01:43 AM Thread Starter
4th Gear Poster
 
KEVIN8989's Avatar
 
Join Date: Aug 2012
Location: Ca
Posts: 295
Garage
Power steering pump whine.

My power steering pump has been quite whiney lately. I have a 92 Supercoupe and had my hydroboost installed from a shop a couple months ago. After its been installed ive had some problems with no brake assist, and a loud power steering with loss of power steering.

After draining the power steering fliud from the power steering cooler hose it and adding new fliud it made the pump alot quieter. The power steering was alot better too. I had a warranty on the hydroboost and had Matt Sweeting fix it. So now it has brake assist but the pump is still too loud and it seems to be getting louder the more I drive it.

I was thinking it may be my varitable assist valve is not working good enough, or something maybe is wrong with the rack and pinion.

Does anyone know what I can buy to connect the hydroboost and power steering pump? I think if I take out the varitable assist valve it can flow better maybe. Any help is much appreciated.
Attached Images
File Type: jpg 20171014_222433.jpg (4.11 MB, 12 views)
File Type: jpg 20170827_140656.jpg (3.83 MB, 9 views)

Last edited by KEVIN8989; 10-15-2017 at 01:51 AM.
KEVIN8989 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-15-2017, 04:22 PM
Moderator
Moderator
 
MaddMartigan's Avatar
 
Join Date: Nov 2002
Location: Pickerington,OH
Age: 31
Posts: 3,555
Garage
Quote:
Originally Posted by KEVIN8989 View Post
My power steering pump has been quite whiney lately. I have a 92 Supercoupe and had my hydroboost installed from a shop a couple months ago. After its been installed ive had some problems with no brake assist, and a loud power steering with loss of power steering.

After draining the power steering fliud from the power steering cooler hose it and adding new fliud it made the pump alot quieter. The power steering was alot better too. I had a warranty on the hydroboost and had Matt Sweeting fix it. So now it has brake assist but the pump is still too loud and it seems to be getting louder the more I drive it.

I was thinking it may be my varitable assist valve is not working good enough, or something maybe is wrong with the rack and pinion.

Does anyone know what I can buy to connect the hydroboost and power steering pump? I think if I take out the varitable assist valve it can flow better maybe. Any help is much appreciated.
I would say that if you remove the variable assist that you would be better off if you're using the hydroboost. The variable assist reduces pressure at higher highway speeds and it seems to me that if you're using the same pressure line then you wouldn't want reduced braking in the same situation.

I believe that you can just remove the variable assist module and put the PS pressure hose straight into the pump.

"When the only tool you have is a hammer, suddenly everything looks like a nail."
"Nothing is foolproof because fools are so ingenious."
1992 Ford Thunderbird SC

Coast High Peformance 347 Stroker
-Low Tension Oil Rings, Zero Gap Seconds
-10.5:1 Compression Ratio
Trick Flow Twisted Wedge heads
Trick Flow Stage 1 cam
Trick Flow Street Heat Intake
Mac 1 5/8 long tube headers
FRPP 42# injectors
3.27 gears
Custom aluminum driveshaft
M5R2
Burned Chip for SN95 T4M0 ECM
OMGHI2U

MaddMartigan is offline  
post #3 of 3 (permalink) Old 01-21-2018, 03:40 AM Thread Starter
4th Gear Poster
 
KEVIN8989's Avatar
 
Join Date: Aug 2012
Location: Ca
Posts: 295
Garage
I finally got my car fixed, my hydroboost return line was plugged into the power steering return line and slowing down the flow. I had my dad help me out and plugged the hydroboost return line directly into the reservour.

Now my car stops and steers alot better, but the stock brake pads are small and cobra brakes will be my next upgrade. Its lots of fun driving this car, its quick, I got a sound system and had tokico blues installed.

Im happy I got my car back on the road. Hopefully traffic will pick up on this site.
Attached Images
File Type: jpg 20180120_212312.jpg (3.90 MB, 10 views)
KEVIN8989 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome