New Sub-Frame - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-02-2004, 12:45 AM Thread Starter
 
Join Date: Jul 2004
Posts: 1,746
New Sub-Frame

Well,

I don't know why I put on another used one, but the old one was messed up pretty bad from a previous collision with a sewer drain.

I spent ALL DAY with the car on a lift (courtesy of my step dad) taking bolts off and what not with him.

Tie Rods, yadada, all a freaking pain in the butt.

So, the next time you think about taking one of those turns faster than normal, take it from me (if you're not a mechanic with access to a shop) don't take it and make the mistake I did, your wallet will be thanking you (1500$ Labor for just the installation of it).

I also think the dipcrackers down the road at time it lube didn’t align my car right at all, the right wheel is now further back than what it was with the horribly bent messed up original sub frame, perhaps I should go to another place in Shreveport?
EPelezo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome