Clunks and stuff.. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 12 (permalink) Old 03-27-2005, 11:54 AM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
Clunks and stuff..

Well I replaced my shocks and struts along with the springs. I got a clunk like somthing it lose. It doesnt seem like anything is lose. I did break a tieroad on the drivers side but I replaced. The others looked fine. any idea what this might be? sounds like the springs are gunna fall out! lmk!

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-27-2005, 03:37 PM
4th Gear Poster
 
Join Date: Sep 2004
Location: Binghamton, NY
Age: 35
Posts: 203
Send a message via AIM to tbirdman93
prob. the usual suspect! ball joints often cause the clunk when hitting things like potholes.

Buy now, Pay later!
tbirdman93 is offline  
post #3 of 12 (permalink) Old 03-28-2005, 12:08 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
good thing the girlfriend works at advanced now

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 03-28-2005, 01:40 PM
Chapter Director Coordinator
Moderator
 
jamesD's Avatar
 
Join Date: Jul 2002
Location: Kissimmee
Age: 37
Posts: 6,253
you didn't check these things while you were in there?
jamesD is offline  
post #5 of 12 (permalink) Old 03-28-2005, 03:32 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
im not that stupid.. everything looked and appeared to work fine

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #6 of 12 (permalink) Old 03-28-2005, 05:58 PM
Chapter Director Coordinator
Moderator
 
jamesD's Avatar
 
Join Date: Jul 2002
Location: Kissimmee
Age: 37
Posts: 6,253
just messin with ya damn.. heh

my boots on the balljoints looked ok too when i swapped springs.. i made mistake of clearing dirt off the boot afterwards and saw they were cracked..
jamesD is offline  
post #7 of 12 (permalink) Old 03-28-2005, 06:27 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
ill probally take it in to get checked out... i dont have time to check that now. Oh well.. But i do have to remove the rear springs to get those bags in

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #8 of 12 (permalink) Old 03-30-2005, 09:38 PM
4th Gear Poster
 
Join Date: Nov 2003
Location: Sterling, VA
Posts: 212
Did you check the strut rod bushings.
wm_sorg is offline  
post #9 of 12 (permalink) Old 03-30-2005, 10:18 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
i fixed it im dumb

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #10 of 12 (permalink) Old 03-30-2005, 11:04 PM
Eleventeenth Gear Poster
 
Aaron K.'s Avatar
 
Join Date: Jul 2002
Location: SoFla
Age: 37
Posts: 3,067
Quote:
Originally Posted by KrAzyT
i fixed it im dumb

What was it?

Sold = 96 Thunderbird
Aaron K. is offline  
post #11 of 12 (permalink) Old 04-02-2005, 02:42 PM Thread Starter
Seasoned PostWhore
 
Join Date: Sep 2002
Location: Erie, PA
Age: 35
Posts: 3,183
Send a message via AIM to KrAzyT
i forgot to put a nut on my swaybar endlink

1996 Thunderbird 4.6 -Sold-
259.4 hp and 285.3 tq on mustang dyno
Bunch of motorcycles
2004 F150
KrAzyT is offline  
post #12 of 12 (permalink) Old 04-02-2005, 07:47 PM
Chapter Director Coordinator
Moderator
 
jamesD's Avatar
 
Join Date: Jul 2002
Location: Kissimmee
Age: 37
Posts: 6,253
front or rear?

if rear.. i wouldn't doubt it.. my rear end links were crappy and kept smackin the side.. heh.. i just replaced the whole bar
jamesD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome