Read the sticky, still have questions on squeaks/rattles/clunks - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 05-15-2005, 06:57 PM Thread Starter
 
Join Date: Mar 2005
Posts: 43
Read the sticky, still have questions on squeaks/rattles/clunks

Okay, well I would like to say I had zero problems with any of the aforementioned problems, until I hit this one HUGE bump when I went into this HUGE thing of mud. The car was doing about....35, and right where the water started there was a 2 foot drop off or so.

As soon as I hit that (or maybe before hand, I'd been doing it for an hour or so, but that was the only really big jolt I hit), all these problems occured:

Upper ball joints are gone. Is there a way to fix these without the 140$ for the parts from advance auto parts? I don't need the control arms, just the joint.

Lower ball joints, can I tell if they're gone without taking the wheel off?

When I'm doing anywhere over 30 mph, and I let off the gas, I hear a clunking noise coming from somewhere in the middle of the car towards the rear. Maybe under the rear seat, maybe between the two front seats, maybe near the rear diff. I can't tell, I can't diagnose it for sure cuz it only happens when the car's in motion. It's very loud though, but there's barely any "jolt".

When the car is shut off, it makes a "pinging" noise (on the outside, on the inside its a popping noise and you can kinda feel it if sitting in your seat.) It happens once every 2 seconds for at least 5 minutes (I've timed it) sometimes it almost 15 minutes. I have NO idea what that could be. It's coming from where the driveshaft goes above/through the gas tank.

There's a little bar that bolts onto the gas tank on both sides, and I guess is an added protection for the driveshaft/gas tank. That is bent to hell and gone. (In the middle its twisted 180 degrees) I guess that's from when I hit a tree stump (I swear to God I didn't see it.)

Oh, and if I shake the rear of the car when its parked, you hear "squeak squeak" as loud as you can possibly imagine. I'm guessing my struts are toast?

The car has 75000 miles on it, and on 7-23-01 it got brand new right left stabilizer links. In June of '04 or so, it got pretty much a brand new suspension.

Fire away...I guess I'll have to put those rims on hold.
AchNgnt is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-16-2005, 01:27 PM Thread Starter
 
Join Date: Mar 2005
Posts: 43
Yummy, now I've noticed a squeaking in my passenger side rear wheel when I let off the gas going over 30 mph.
AchNgnt is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome