addco prob. - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 06-13-2005, 07:37 PM Thread Starter
4th Gear Poster
 
Join Date: Sep 2004
Location: Binghamton, NY
Age: 35
Posts: 203
Send a message via AIM to tbirdman93
addco prob.

has anyone had an addco 1.25" front sway bar hit their shock. i just did a rebuild and mine is hitting on both sides. any info. would help.

Buy now, Pay later!
tbirdman93 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-15-2005, 08:04 PM
4th Gear Poster
 
Franky-5-Fingaz's Avatar
 
Join Date: Oct 2004
Location: FairfaX, VA
Age: 31
Posts: 332
Send a message via AIM to Franky-5-Fingaz
is your car lowered at all? if not, then ya got me, so bump

CarDomain Bird My T-bird

4.6L V8..
.... a Couple little bolt-ons.
Franky-5-Fingaz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome