Cooling System Help - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 11-30-2011, 01:38 PM Thread Starter
3rd Gear Poster
 
blkadder's Avatar
 
Join Date: Feb 2006
Location: West Palm Beach, Florida
Age: 54
Posts: 192
Cooling System Help

Greetings,
My 94 Cougar 3.8 started overheating today, and from the symptoms, I figured it was the t-stat is bad. The upper hose is hot, but the left side of the radiator is cold to the touch.

I changed out the original t-stat, figuring it is the easiest to do. I followed the refill procedure for the 3.8 and the car will run, but the temp gauge gets pretty high, even with the fan running. The left side of the radiator is cool to the touch, but the right side is hot to the touch.

The radiator is less than a year or so old, along with the water pump, and of course the t-stat.

I am kind of at a loss here, so any help is greatly appreciated.

Ron

...Semper Fidelis...
blkadder is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome