Dirty Fuel Injectors! - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 07-15-2002, 03:51 PM Thread Starter
 
Join Date: Jul 2002
Posts: 26
Post Dirty Fuel Injectors!

The two front fuel injectors (left and right) in my 4.6L
are dirty with black engine oil. Ford just replaced my
intake manifold a month ago (the orginal manifold
was actually OK.) Any clues? I can't think why
oil goes to injectors, and yes just two of them.
I can smell something from there after a relatively
long drive. Any input appreciated!
bbird is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-15-2002, 04:49 PM
Mushroom Stamp Layer
 
seabass's Avatar
 
Join Date: Jul 2002
Location: 127.0.0.1
Age: 40
Posts: 844
you sure oil didn't just get spilled on them? Do you have a picture of them?

Seabass
seabass is offline  
post #3 of 3 (permalink) Old 07-15-2002, 10:52 PM
 
Join Date: Jul 2002
Posts: 286
If the oil was on the outside of the injector tips, I wouldn't worry about the injectors unless you were getting trouble codes. I would worry about where the oil was coming from.

If oil were spilled so it got into the injector O-ring area, it might get sucked past the seal. Some people oil up the seals and bores before installing injectors - less wear on the O-rings.
bill_s is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome