gas leak - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 12-15-2010, 11:13 AM Thread Starter
Newbie
 
Join Date: Dec 2010
Location: corbin,ky
Posts: 6
gas leak

has anybody had any trouble with their gas tank leaking around the fuel pump i changed the ring two or three times i tried sealing it with seal all but it still leaks i dont know if it is common in thunderbirds or if it is just mine but i would like to know a solution to fix it.




thanks
19tbird96 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 12-15-2010, 11:56 AM
4th Gear Poster
 
tbirdsps's Avatar
 
Join Date: Jan 2003
Location: Ridgecrest, Ca
Age: 66
Posts: 267
Quote:
Originally Posted by 19tbird96 View Post
has anybody had any trouble with their gas tank leaking around the fuel pump i changed the ring two or three times i tried sealing it with seal all but it still leaks i dont know if it is common in thunderbirds or if it is just mine but i would like to know a solution to fix it.




thanks
Mine leaks but only when completly full. I'm going to change the whole fuel pump and float assembly. I have the part but I'm trying to burn the gas off to at least 2-3 gallons before I do the deed.

I've dropped the tank before and replaced the return hose as it was dirty/greasy looking but that wasn't the problem. I'm hoping replacing the whole assembly will do the trick as it needs a new float anyway. It sticks when full and drops only when it gets down to a quarter tank.
tbirdsps is offline  
post #3 of 7 (permalink) Old 12-15-2010, 02:46 PM
6th Gear Poster
 
davis97xr7's Avatar
 
Join Date: Jan 2007
Location: Minnesota
Age: 32
Posts: 557
it's fairly common for one of the lines to leak

-Joe-
1994 Ford Thunderbird SC 5-Speed
1996 Ford Mustang SVT Cobra #1251
davis97xr7 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 12-15-2010, 05:52 PM Thread Starter
Newbie
 
Join Date: Dec 2010
Location: corbin,ky
Posts: 6
i checked the lines neither one is broke but you can see where the gas is escaping around the fuel pump and running down the tank.
19tbird96 is offline  
post #5 of 7 (permalink) Old 12-18-2010, 04:16 PM
1st Gear Poster
 
Join Date: Aug 2010
Location: Missouri
Age: 28
Posts: 39
i have this same problem with my thunderbird as what 19tbird said and mine also does this when full so i just fill it to 3/4
Travis_Holt is offline  
post #6 of 7 (permalink) Old 02-16-2011, 12:21 AM
PostWhore
 
CrystalPistol's Avatar
 
Join Date: Aug 2003
Location: Shenandoah Valley
Age: 65
Posts: 1,032
Quote:
Originally Posted by Travis_Holt View Post
i have this same problem with my thunderbird as what 19tbird said and mine also does this when full so i just fill it to 3/4
X3 except when I am gonnea use the fuel.

A fine pair ... ... and whatever you do, Have a Safe Trip!
CrystalPistol is offline  
post #7 of 7 (permalink) Old 02-16-2011, 07:36 AM
4th Gear Poster
 
tbirdsps's Avatar
 
Join Date: Jan 2003
Location: Ridgecrest, Ca
Age: 66
Posts: 267
Mine is fixed. I replaced the whole pump/sending unit with a new seal and all is well. Let me tell you that the ethanol in the fuel is doing nobody any favors. It's amazing that the pump still worked. Very corroded and the seal was like swiss cheese. The plastic parts are very brittle on the old assembly.
tbirdsps is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome