97 Mark 8 P0705 - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-17-2011, 11:09 AM Thread Starter
SuperNewbie
 
supergordo's Avatar
 
Join Date: Nov 2005
Location: Las Vegas
Posts: 2,869
Garage
Send a message via Yahoo to supergordo
97 Mark 8 P0705

I'm working on a 97 Mark 8 that has a P0705 troublecode. I know that this is a range sensor fault. I replaced the MLPS with a known good one and the problem persists. The info center on the dash states "Gear shift selector malfunction". When you put the car into reverse the "R" indicator on the dash lights up, as will the one on the shifter in the center console. Once you put it into drive the D will light up momentarily on the dash then goes out. The D on the shifter doesn't light up at all.
I've cleaned all the connections on the wiring harness on the tranny, no change. Replaced the MLPS, no change. Adjusted the MLPS, no change.

Has anyone else experienced anything like this? I was thinking that thecircut board with the LED's on it that illuminates the shifter may be bad, or possibly the computer itself not reading the signal from the wiring.

Thanks in advance for your thoughts and related experience on this.

1995 Cougar XR7 4.6
1997 Thunderbird LX 4.6
1977 Country Squire 460
1985 Capri RS 5.0, 5spd
1997 Thunderbird 4.6
1984 Capri RS 5.0,5spd
supergordo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome