My 95 steering issues - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-23-2016, 01:29 PM Thread Starter
Newbie
 
Join Date: Apr 2016
Location: Conover, NC
Age: 36
Posts: 7
Garage
Exclamation My 95 steering issues

Seems like no power steering when backing up or at low rpm's going forward no issues any idea what may be causing this?
Mike e is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-23-2016, 03:46 PM
Seasoned PostWhore
 
theterminator93's Avatar
 
Join Date: Jan 2009
Location: North Ridgeville, Ohio
Age: 31
Posts: 9,037
Garage
When was the last time a PS system flush was done?

-Brandon
97 Laser Red Thunderbird LX 161k, Stage 2 4.6L 2v N/A | 300 BHP (255 RWHP, 290 RWTQ) | 13.95 @ 97.58 | Build details | Pics at the Lorain Assembly plant
98 Black Mark VIII 155k, stock daily driver
07 Redfire Fusion V6 SEL 178k, for the wife
Gone but not forgotten: 96 Mark VIII, 94 Cougar XR7, 93 Mark VIII

TCCoA's resident pilot since 2014
Once you have tasted flight, you will walk the world with your eyes turned skyward, for there you have been and there you long to return. -Leonardo da Vinci
theterminator93 is offline  
post #3 of 5 (permalink) Old 04-23-2016, 07:36 PM Thread Starter
Newbie
 
Join Date: Apr 2016
Location: Conover, NC
Age: 36
Posts: 7
Garage
Right after I bought it about 3 weeks ago

It's almost like it wants to stall out most the time when I'm backing up the rpm drops to about 200-300 and it's like manual steering..

Last edited by Rodeo Joe; 04-24-2016 at 05:11 AM. Reason: Merged posts
Mike e is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-23-2016, 09:23 PM
Humble MN12 Genius
Super Moderator
 
XR7-4.6's Avatar
 
Join Date: Apr 2006
Location: Roselle IL
Posts: 16,578
Garage
Send a message via Yahoo to XR7-4.6
If your engine is running at 300rpm power steering is not the problem, in fact your symptoms sound normal in that instance since the pump won't produce adequate boost at that low of RPM.

-Matt
XR7-4.6 is offline  
post #5 of 5 (permalink) Old 04-24-2016, 07:28 AM Thread Starter
Newbie
 
Join Date: Apr 2016
Location: Conover, NC
Age: 36
Posts: 7
Garage
This only happens when backing up it idles around 800 rpm at in park or neutral in drive drops to around 6-700 rpm which is normal rpm range
Mike e is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome