Radio no sound? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-23-2019, 08:09 PM Thread Starter
5th Gear Poster
 
gordonm1's Avatar
 
Join Date: Nov 2012
Location: Yakima, WA
Posts: 468
Radio no sound?

I went out to start up the 'bird after a couple months and the battery was almost dead and I had to charge it. The battery seems charged and test drove it around town but I can't get any noise from the stereo/radio. I thought i might hear some hiss at hi volume but there is nothing even though all buttons seem to work on the radio.

Does that point to anything?

All that ever happened with the stereo was I had a Kenwood cassette/radio with remote CD changer put in a long time ago.

1992 Tbird LX 5.0, 3.73 gears, 1995 Cobra intake, deleted air silencer, 2.5" mandrel bent dual exhaust, SCP shorty headers. Updated four-hole fuel injectors. SK shift kit in AOD. Vogtland 0.9" springs, Tokico and Bilstein shocks.
gordonm1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-24-2019, 11:08 AM
Kind of slapped together
 
Join Date: Jan 2010
Location: Bossier City, LA
Age: 63
Posts: 4,786
I've had that happen a few times on the head unit in my Dodge Dakota.

What works for me is to turn ignition off, pull out the keep-alive fuse, count to 10, and plug it back in.

For some reason, once in a blue moon, these things get "confuzickated" and forget to turn the amp on ...

RwP

Fuelly
RalphP is offline  
post #3 of 5 (permalink) Old 03-24-2019, 01:51 PM Thread Starter
5th Gear Poster
 
gordonm1's Avatar
 
Join Date: Nov 2012
Location: Yakima, WA
Posts: 468
I'm trying to remember I think there is a reset button in the trunk for the head unit or something. It's raining today so I can do more reading.

I'll have to look up the "Keep Alive" fuse and where it is. Basically, I need to start the electrical troubleshooting after some more searching here on the forum. That usually starts with the fuses

1992 Tbird LX 5.0, 3.73 gears, 1995 Cobra intake, deleted air silencer, 2.5" mandrel bent dual exhaust, SCP shorty headers. Updated four-hole fuel injectors. SK shift kit in AOD. Vogtland 0.9" springs, Tokico and Bilstein shocks.
gordonm1 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 03-24-2019, 03:36 PM Thread Starter
5th Gear Poster
 
gordonm1's Avatar
 
Join Date: Nov 2012
Location: Yakima, WA
Posts: 468
Got it working by pulling and reinstalling the radio fuse in the fuse box under the dash and the same to the 5 amp memory fuse in the large power box next to the battery. It may have been the memory needed a jolt because the radio was powering up before. Both were good and reused.

It could also have just needed to have the battery disconnected to reset whatever the memory fuse protects

Now what to do in wet weather? Taxes!!!

Thanks all

1992 Tbird LX 5.0, 3.73 gears, 1995 Cobra intake, deleted air silencer, 2.5" mandrel bent dual exhaust, SCP shorty headers. Updated four-hole fuel injectors. SK shift kit in AOD. Vogtland 0.9" springs, Tokico and Bilstein shocks.

Last edited by gordonm1; 03-24-2019 at 03:43 PM. Reason: reasons
gordonm1 is offline  
post #5 of 5 (permalink) Old 03-25-2019, 05:43 AM
MA Chapter Director

Administrator
 
Rodeo Joe's Avatar
 
Join Date: Jul 2002
Location: Franklin, MA
Age: 62
Posts: 7,842
Garage
Quote:
Originally Posted by gordonm1 View Post
Now what to do in wet weather?


Joe

It's not a 97 Sport, it just looks like one!

Mass. TCCoAers, Send me your info!

I buy all my Ford parts from 93 lx.

Member of the TCCoA Damage Control Team.

R.I.P. Johnny Langton 1975 - 2011
Rodeo Joe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 



Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Radio Won't Come Out even with Radio Removal Tools, Any Suggestions? 06jeep Interior 7 04-21-2015 02:22 AM
No cam, no exhaust, no big V8..... NO PROBLEM!!!! _95badbird Videos/Images 19 02-14-2010 10:45 AM
No radio/No Clock Peppers30 Audio / Electronics 12 12-30-2007 03:05 PM
How do I enter radio code to stock 2006 radio? Andy625UK Audio / Electronics 21 02-07-2007 09:53 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome