Oil pressure gauge on a 88 Cougar - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 12-03-2003, 08:06 AM Thread Starter
 
Join Date: May 2003
Posts: 2,230
Oil pressure gauge on a 88 Cougar

A man came into the store the other day and said that he had a 88 Cougar 5.0. He said that he thinks he needs a new oil sending unit, and if he could install it in the parking lot. Intrigued I followed him outside. He said that when he turns his car on, but does not start it the oil pressure gauge (I know, it is not a real oil pressure gauge but a "dummy" one) will go up all the way. But when he starts the car it will go up all the way and then decend down to red area. This is happening now even after the new unit was installed. What is wrong with this guys car? Is it an electrical problem or what? I told him to call in a few days to see if I can find anything out.
lightevergreenfrost is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome