rpm dropping - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 12-05-2003, 03:59 PM Thread Starter
1st Gear Poster
 
Join Date: Sep 2002
Location: spfld ma
Age: 38
Posts: 50
Send a message via AIM to toymrj Send a message via Yahoo to toymrj
rpm dropping

it mostly does it when the car is cold but still does it sometimes when car is warmed up but not too often. when i press the gas down the car pretty much buckles or should i say the rpm drop down like 500 (somewhere between that 300-500rpms) then a sec later it jumps up then the car goes but it just buckles for a sec. i pulled a code that the egr solenoid was stuck in the wide open position. so dont even if that is what is causing the problem and just changed my spark plug wires and spark plugs and cleaned the maf. any suggestions are great?
toymrj is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-08-2003, 10:41 AM
Trumpeter Extraordinaire
 
IronChopz's Avatar
 
Join Date: Jul 2002
Location: Saturn (or SE Michigan)
Age: 57
Posts: 2,916
Which code exactly did you get? If the code indicates the EGR solenoid is stuck open, it could be a faulty EGR solenoid (~$32). It's a relatively easy replacement, and has a vacuum connection on it. I was able to change the solenoid in about ten minutes, despite not being able to see the bolts directly.

It's part #4 in this diagram...


IronChopz is offline  
post #3 of 6 (permalink) Old 12-08-2003, 04:48 PM Thread Starter
1st Gear Poster
 
Join Date: Sep 2002
Location: spfld ma
Age: 38
Posts: 50
Send a message via AIM to toymrj Send a message via Yahoo to toymrj
yea thats what i thought but the thing is advanced auto and autozone did not have the part.
toymrj is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 12-08-2003, 06:58 PM
Trumpeter Extraordinaire
 
IronChopz's Avatar
 
Join Date: Jul 2002
Location: Saturn (or SE Michigan)
Age: 57
Posts: 2,916
Very true. After finding out those places don't carry that part, I got a replacement from the dealership.
IronChopz is offline  
post #5 of 6 (permalink) Old 12-08-2003, 08:35 PM Thread Starter
1st Gear Poster
 
Join Date: Sep 2002
Location: spfld ma
Age: 38
Posts: 50
Send a message via AIM to toymrj Send a message via Yahoo to toymrj
how much was it from the dealer. the $32 dollars u said it was right.
toymrj is offline  
post #6 of 6 (permalink) Old 12-08-2003, 10:43 PM
 
Join Date: Sep 2002
Posts: 217
I had the same exact problem on our family's '94 Tbird. When it is cold and you give it gas, RPMS drop, the car stumbled, then a second later rpms increase and its fine. Only had the problem when accelerating from a stop. I replaced the MAF even though I cleaned it, and the problem never came back.
Annihilator is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome