Electric water pump? - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 02-05-2004, 07:55 PM Thread Starter
 
Join Date: Aug 2002
Posts: 138
Electric water pump?

Would it be worth the $$$ to buy an electric water pump? What are the advantages and disadvantages of having an electric one?
crisqob is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-06-2004, 12:32 AM
Refrigerator Raider Hater
Moderator
 
GreenBird's Avatar
 
Join Date: Jul 2002
Location: Vermont
Age: 36
Posts: 11,719
The Meziere is the only one I'm familiar with. It seems to have a good record for reliability, and it's suppoedly worth ~10hp so it's a decent mod. If you decide to do it, I would suggest a way to monitor the pump's activity. Wouldn't want it to fail and not know...




Matt "Looks Like Egon" Davis
96 Alpine Green V8
98 Audi A8 4.2Q in Racing Green Totalled
02 Audi A8L 4.2Q in Black

I buy my OEM Ford parts at 10% over dealer cost from Steve in White Bear Lake, MN.
You drive "like a man possessed"... by a woman!
GreenBird is offline  
post #3 of 4 (permalink) Old 02-07-2004, 02:20 AM
2nd Gear Poster
 
Join Date: Jul 2002
Location: Monterey Park, California
Age: 51
Posts: 86
I've had mine for a year now with no problems. I'm very happy with it. 55 GPH flow rate provides excelent cooling on the street and at the track. As far as power goes Mezier claims 10-15 horspower and at least that much torque. I don't have a dyno sheet to verify that but I will say i felt a bigger increase in power through out the rev range with this pump than I did with the Steeda pullies. Plus no charging and overheating problems unlike with the Steeda pullies. If you buy this pump do not connect the power wire to the alternator like the instructions say. Connect it to the battery. Connecting anything to the alternator will cause it to stay on continuosly and eventually fry it. I pointed this out to Mezier but i don't know if they ever corrected the instructions. As far as reliability goes they wont last as long as a regular pump but all pumps eventually do fail. The pump on my old engine failed with out leaking any antifreeze or steam. i knew something was wrong when the temp gauge started flying towards red so I pulled over and called AAA . The impellar blade had separated from the shaft!! It took me just 30 min to replace it. Try doing that on a 5.0 So just keep an eye on your temp gauge, in fact keeping an eye on all your gauges should be a habit.

2000 GT engine

Nakamichi CD 500, Nakamichi MB 70 in dash cd changer, three Nakamichi amps (1000 watts), 10 inch sub, MB Quart speakers (4 5x7 and 2 6x9)

2003 Mustang Mach 1


"The fast ones always ride for free"
Andrew Wood (R.I.P.) Mother Love Bone

Last edited by BlackBird; 02-07-2004 at 02:34 AM.
BlackBird is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-07-2004, 11:00 AM
MaleWhore
 
smokymance's Avatar
 
Join Date: Oct 2003
Location: Commerce , MI
Posts: 2,640
Send a message via AIM to smokymance
anyone have any links or pics of these pumps...never seen them on a 4.6

1997 MN12 Sport 4.6L Supercharged 5 Speed Sold
1998 Mark VIII LSC Teredor Red, Parts car, PM me
1998 Mark VIII LSC Pearl, Stock, Garage Queen
2000 Jeep XJ 4.0L Long Armed and Locked
2008 Yukon Denali 6.2L Supercharged
smokymance is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome