Running bad - TCCoA Forums
 
LinkBack Thread Tools
post #1 of 13 (permalink) Old 03-09-2013, 09:39 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Running bad

Ok, my Bird is really acting up. When I start it, it barely stays on at 550 RPMs. Jitters between them also. After about 10 minutes, it gets up to 700 RPMs, and runs fine. Any ideas? I've cleaned out the IAC, MAF, checked spark plugs (new spark plugs), wires, coil packs.

I'm wondering if its the O2 sensors. I can tell its running rich also, from the dark stuff coming out of the mufflers. And the really bad smell, I guess my Cats are shot.

I will be getting it checked tomorrow at Orileys, since its an OBI, the test results should take a couple of minutes to get. It runs like total crap.

-SVT

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.
SVT Thunderbird is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-09-2013, 10:02 PM
Moderator & Teksid Whore
Super Moderator
 
guitar maestro's Avatar
 
Join Date: Jul 2002
Location: Laredo, Texas
Age: 39
Posts: 11,961
Send a message via MSN to guitar maestro Send a message via Yahoo to guitar maestro
Get the codes scanned first.

When you say you cleaned out the wires and coils, what does that mean?

O2 sensors are not used at start up. Doesn't mean that they dont need replacing though.

Get the fuel pressure with and without vacuum on the regulator.
guitar maestro is offline  
post #3 of 13 (permalink) Old 03-09-2013, 10:50 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Quote:
Originally Posted by guitar maestro View Post
Get the codes scanned first.

When you say you cleaned out the wires and coils, what does that mean?

O2 sensors are not used at start up. Doesn't mean that they dont need replacing though.

Get the fuel pressure with and without vacuum on the regulator.
I will get the codes as soon as O'rileys opens tomorrow.

I replaced the spark plug wires, and the Ignition coil packs themselves due to one of the coil packs failing on me. Replaced them with new ones. I didn't see that I was to vague at first.

O2 sensors I have to change out either way.

How would i go about getting the fuel pressure with and without the vacuum regulator? I honestly don't know of any ideas.

Thanks!

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.
SVT Thunderbird is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 03-09-2013, 11:16 PM
Moderator & Teksid Whore
Super Moderator
 
guitar maestro's Avatar
 
Join Date: Jul 2002
Location: Laredo, Texas
Age: 39
Posts: 11,961
Send a message via MSN to guitar maestro Send a message via Yahoo to guitar maestro
No, you're not understanding me properly about the fuel pressure. Please familiarize yourself with the fuel pressure regulator on your car. Pop the hood, take a picture if you have to point out anything that is unfamiliar, and re-read the line I wrote last in my previous reply.
guitar maestro is offline  
post #5 of 13 (permalink) Old 03-10-2013, 02:44 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Quote:
Originally Posted by guitar maestro View Post
No, you're not understanding me properly about the fuel pressure. Please familiarize yourself with the fuel pressure regulator on your car. Pop the hood, take a picture if you have to point out anything that is unfamiliar, and re-read the line I wrote last in my previous reply.
Ok, I disconnected the vacuum line that leads into the fuel pressure regulator, and plugged it back in. No change in the way the car acted. Still barely stays on at 550 RPMs.

I'm currently at O'rielys getting the car checked through an OBI Scanner. Codes should be mine in a couple of minutes. Maybe this could shed a better light on my problem.

-SVT

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.
SVT Thunderbird is offline  
post #6 of 13 (permalink) Old 03-10-2013, 03:06 PM
Moderator & Teksid Whore
Super Moderator
 
guitar maestro's Avatar
 
Join Date: Jul 2002
Location: Laredo, Texas
Age: 39
Posts: 11,961
Send a message via MSN to guitar maestro Send a message via Yahoo to guitar maestro
Quote:
Originally Posted by SVT Thunderbird View Post
Ok, I disconnected the vacuum line that leads into the fuel pressure regulator, and plugged it back in. No change in the way the car acted. Still barely stays on at 550 RPMs.

I'm currently at O'rielys getting the car checked through an OBI Scanner. Codes should be mine in a couple of minutes. Maybe this could shed a better light on my problem.

-SVT
that's not how you check fuel pressure, but ok.

Code readings always help.
guitar maestro is offline  
post #7 of 13 (permalink) Old 03-10-2013, 03:53 PM
PostWhore
 
nall_one's Avatar
 
Join Date: Mar 2007
Location: Hickman Nebraska
Age: 31
Posts: 1,273
Garage
vacuum tee leak? you may want to get a can of carb cleaner and start spraying around the back of the intake where the lines from the PCV go. that thing tends to suck closed and/or rip open creating a large leak.

otherwise has the fuel filter been changed ever? passenger side, under the car along the frame rail, under a small plate held on with an 8mm bolt.

and yes, checking the fuel pressure would be a good idea. get yourself a fuel pressure gauge, oreillys rents, and sells them. theirs a small black plastic cap on the fuel rail somewhere that has a schrader valve under it, connect the gauge and see what it says for pressure at idle and under throttle, should be somewhere around 40-50. might want to change the fuel filter first if it has indeed never been changed...

sometimes if the hose its long enough on that gauge feeding it under the hood so you can see it from the driver seat and taking her for a drive is also required to see if the pressure drops under load or WOT.

something else i forgot to mention... being a 94 i sure hope your ECM isn't toast hanging injectors open. dose it smell horribly like raw fuel? might also be a good idea to get a stethoscope and start listening to those injectors one at a time. see if their all ticking regularly.

RUST!! eating away at me more than the rear fender wells
95 Deep Jewel Green 40th Anniversary Bird / Stock SOHC 190k 96-97 intake swap, 97 Mk8 4R70W, Jmod, 3L27 / energy susp rear spindle, and cobra arm bushings, 93 Mk8 shaft, and LCAs, 225/60r16 on Windstar twin 5spokes, Vogtland 1.6drop springs, Tokico Blues, PBR, and rear-disk swap, 89 SC swaybars

Last edited by nall_one; 03-10-2013 at 04:13 PM.
nall_one is offline  
post #8 of 13 (permalink) Old 03-10-2013, 04:51 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Quote:
Originally Posted by guitar maestro View Post
that's not how you check fuel pressure, but ok.

Code readings always help.
I figured it out. I hooked up a fuel pressure gauge, and came up with 46 psi at idle, and 50 psi at throttle. Seems about right where it should be.

Code P0173, and that's about it. Its coming up as a vacuum leak. I can't seem to hear the general area where it may be located.

Quote:
Originally Posted by nall_one View Post
vacuum tee leak? you may want to get a can of carb cleaner and start spraying around the back of the intake where the lines from the PCV go. that thing tends to suck closed and/or rip open creating a large leak.

otherwise has the fuel filter been changed ever? passenger side, under the car along the frame rail, under a small plate held on with an 8mm bolt.

and yes, checking the fuel pressure would be a good idea. get yourself a fuel pressure gauge, oreillys rents, and sells them. theirs a small black plastic cap on the fuel rail somewhere that has a schrader valve under it, connect the gauge and see what it says for pressure at idle and under throttle, should be somewhere around 40-50. might want to change the fuel filter first if it has indeed never been changed...

sometimes if the hose its long enough on that gauge feeding it under the hood so you can see it from the driver seat and taking her for a drive is also required to see if the pressure drops under load or WOT.

something else i forgot to mention... being a 94 i sure hope your ECM isn't toast hanging injectors open. dose it smell horribly like raw fuel? might also be a good idea to get a stethoscope and start listening to those injectors one at a time. see if their all ticking regularly.
To my knowledge the fuel filter has never been replaced. The pressure does drop to around 49 psi when I take her for a drive. But it keeps running fine. Occasionally It wants to die, when I stop at a light.

It smells like raw eggs. I will try your stethoscope idea.

I will check the back area of the intake manifold right now. Something tells me its the vacuum tee for some odd reason.

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.
SVT Thunderbird is offline  
post #9 of 13 (permalink) Old 03-10-2013, 05:16 PM
Moderator & Teksid Whore
Super Moderator
 
guitar maestro's Avatar
 
Join Date: Jul 2002
Location: Laredo, Texas
Age: 39
Posts: 11,961
Send a message via MSN to guitar maestro Send a message via Yahoo to guitar maestro
Quote:
Originally Posted by SVT Thunderbird View Post
I figured it out. I hooked up a fuel pressure gauge, and came up with 46 psi at idle, and 50 psi at throttle. Seems about right where it should be.

Code P0173, and that's about it. Its coming up as a vacuum leak. I can't seem to hear the general area where it may be located.
First of all, you when you take fuel pressure readings, you need to state if you

A. Left the vacuum hose plugged into the fuel pressure regulator
OR
B. removed the vacuum hose off of the fuel pressure regulator.

My guess is that you left the vacuum hose in place. IF that is the case, your fuel pressure is way too high, assuming the fuel pressure tester is working properly. At idle, you should be seeing around 33 psi a couple psi. At wot, under this same scenario, the fuel pressure should rise to 39psi .

Again, assuming the fuel pressure tester/gauge is working properly, this says that your fuel pressure regulator is malfunctioning and could easily account for the rich condition you seem to have "diagnosed" via black soot coming out the tailpipes.

It seems to me, that the idle is not correcting itself right away because the STFTs take time to get transferred into LTFTs, and the STFT's don't always have enough adjustability to trim out the fuel necessary, which might explain the delay you are seeing before the idle steadies itself out. See if you can get both the STFTs and the LTFTs while the car is sitting idling.


Quote:
Originally Posted by nall_one View Post
should be somewhere around 40-50
ya might wanna take note of the above numbers. I don't care what shop manuals say, the correct fuel pressure at idle with vacuum applied to the regulator from the manifold should be 39.15 psi minus (#_of_in-Hg_vacuum converted to psi)---in most cases this leads to around 32-34 psi at the rail.

Don't get me wrong, a car is drive-able (depending on your definition of "drive-able") if the fuel pressure is higher than this, but this is only because the adaptive fueling logic in the PCM ends up using it's adjustability in order to try and trim out the excess fuel---and sometimes (such as in this case) is not enough and leads to issues.

Last edited by guitar maestro; 03-10-2013 at 05:27 PM.
guitar maestro is offline  
post #10 of 13 (permalink) Old 03-10-2013, 10:42 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Quote:
Originally Posted by guitar maestro View Post
First of all, you when you take fuel pressure readings, you need to state if you

A. Left the vacuum hose plugged into the fuel pressure regulator
OR
B. removed the vacuum hose off of the fuel pressure regulator.

My guess is that you left the vacuum hose in place. IF that is the case, your fuel pressure is way too high, assuming the fuel pressure tester is working properly. At idle, you should be seeing around 33 psi a couple psi. At wot, under this same scenario, the fuel pressure should rise to 39psi .

Again, assuming the fuel pressure tester/gauge is working properly, this says that your fuel pressure regulator is malfunctioning and could easily account for the rich condition you seem to have "diagnosed" via black soot coming out the tailpipes.

It seems to me, that the idle is not correcting itself right away because the STFTs take time to get transferred into LTFTs, and the STFT's don't always have enough adjustability to trim out the fuel necessary, which might explain the delay you are seeing before the idle steadies itself out. See if you can get both the STFTs and the LTFTs while the car is sitting idling.




ya might wanna take note of the above numbers. I don't care what shop manuals say, the correct fuel pressure at idle with vacuum applied to the regulator from the manifold should be 39.15 psi minus (#_of_in-Hg_vacuum converted to psi)---in most cases this leads to around 32-34 psi at the rail.

Don't get me wrong, a car is drive-able (depending on your definition of "drive-able") if the fuel pressure is higher than this, but this is only because the adaptive fueling logic in the PCM ends up using it's adjustability in order to try and trim out the excess fuel---and sometimes (such as in this case) is not enough and leads to issues.
Correct, I left the vacuum hose in place. I re-took the readings. Still showing 46 psi, and 51 psi at throttle.

I went ahead and replaced the fuel filter, and found that its not staying at 550 RPMs anymore, its up to 600 RPMs, but still takes about 10 minutes to idle correct.

I will be reading the STFT, and LTFTs tomorrow. If that's my problem, other than the vacuum leak which I found was the vacuum tee (small fix). I will probably have to buy a new Fuel Pressure regulator.

I really appreciate the help you've given me! Seems like I'm getting closer and closer to its normal state. I really do thank you @Guitar Maestro!

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.

Last edited by guitar maestro; 03-11-2013 at 12:23 AM. Reason: fixed "Maestro" spelling lol
SVT Thunderbird is offline  
post #11 of 13 (permalink) Old 03-11-2013, 12:22 AM
Moderator & Teksid Whore
Super Moderator
 
guitar maestro's Avatar
 
Join Date: Jul 2002
Location: Laredo, Texas
Age: 39
Posts: 11,961
Send a message via MSN to guitar maestro Send a message via Yahoo to guitar maestro
Quote:
Originally Posted by SVT Thunderbird View Post
Correct, I left the vacuum hose in place. I re-took the readings. Still showing 46 psi, and 51 psi at throttle.

I went ahead and replaced the fuel filter, and found that its not staying at 550 RPMs anymore, its up to 600 RPMs, but still takes about 10 minutes to idle correct.

I will be reading the STFT, and LTFTs tomorrow. If that's my problem, other than the vacuum leak which I found was the vacuum tee (small fix). I will probably have to buy a new Fuel Pressure regulator.

I really appreciate the help you've given me! Seems like I'm getting closer and closer to its normal state. I really do thank you @Guitar Maestro!
Fix any and all vacuum leaks first before buying a new FPR. You gotta remember, the fuel pressure regulator is vacuum-assisted. Not that it could do without the assistance--it actually needs vacuum to operate correctly, and vacuum leaks disturb it's normal operation. If any vacuum leaks persist, you'll end up chasing your tail trying to find the problem.
guitar maestro is offline  
post #12 of 13 (permalink) Old 03-11-2013, 07:00 PM
PostWhore
 
nall_one's Avatar
 
Join Date: Mar 2007
Location: Hickman Nebraska
Age: 31
Posts: 1,273
Garage
yeah, on those 95's its usually that tee, and/or the elbow on the other side. they connect right to the intake ports via a channel in the intake and the gaskets. if theirs a leak their it makes a rather bad run-ability issue. when i got my intake off for the manifold swap i found that the elbow was sucked closed/torn open.

RUST!! eating away at me more than the rear fender wells
95 Deep Jewel Green 40th Anniversary Bird / Stock SOHC 190k 96-97 intake swap, 97 Mk8 4R70W, Jmod, 3L27 / energy susp rear spindle, and cobra arm bushings, 93 Mk8 shaft, and LCAs, 225/60r16 on Windstar twin 5spokes, Vogtland 1.6drop springs, Tokico Blues, PBR, and rear-disk swap, 89 SC swaybars
nall_one is offline  
post #13 of 13 (permalink) Old 03-11-2013, 10:05 PM Thread Starter
3rd Gear Poster
 
SVT Thunderbird's Avatar
 
Join Date: May 2012
Location: Prescott, Arizona
Posts: 144
Send a message via Skype™ to SVT Thunderbird
Quote:
Originally Posted by guitar maestro View Post
Fix any and all vacuum leaks first before buying a new FPR. You gotta remember, the fuel pressure regulator is vacuum-assisted. Not that it could do without the assistance--it actually needs vacuum to operate correctly, and vacuum leaks disturb it's normal operation. If any vacuum leaks persist, you'll end up chasing your tail trying to find the problem.
Fixed my overall problem! I found that the vacuum tee, and a little vacuum hose had holes in them, and I made a trip to the local U-Pick it, and got a Fuel pressure regulator off a 95 Bird, that had low miles (65k, rear end collision), and replaced it into mine. Works like new again! Really happy! I even went ahead, and replaced the brake shoes, and bleed my entire system. Feels like its brand new!

Quote:
Originally Posted by nall_one View Post
yeah, on those 95's its usually that tee, and/or the elbow on the other side. they connect right to the intake ports via a channel in the intake and the gaskets. if theirs a leak their it makes a rather bad run-ability issue. when i got my intake off for the manifold swap i found that the elbow was sucked closed/torn open.
Thanks for the suggestion! I found that it was a small hose near the vacuum tee, and the vacuum tee its self causing the vacuum leak. Runs great now!

AZ Member
- 90 SC, Custom Exhaust, Cobra R hood, Tinted, Lowered, sound system, and small goodies.
-94 4.6L "SVTBIRD", custom exhaust, custom sound system, New paint, Tinted, small goodies.
-94 SC Auto, tinted, Cobra R's 275/40/17s all the way around, Mac CAI, FMIC soon, And some other go fast stuff.
-94 SC 5spd, Black.. needs paint job, and head gaskets.
SVT Thunderbird is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome