97 t-bird EECU F7SF-AA information - TCCoA Forums
 1Likes
  • 1 Post By nabeel11
 
LinkBack Thread Tools
post #1 of 16 (permalink) Old 10-19-2016, 06:15 AM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Question 97 t-bird EECU F7SF-AA information

Hello everybody;
This is my first post so before I ask let me introduce my self and my car. My name is Nabeel, 33 years. I live in Libya -a country to the south of Italy. I recently purchased 97 t-bird -the only one t-bird in the country. This t-bird has plenty of black smoke out of the exhaust. Scan tool shows that all O2 heater circuits are malfunction. after testing I found out it is my PCM who caused these codes, this is expected from the beginning because it is not normal to have all four O2 sensor circuits fail.
Now I am stuck. The part number is f7sf-12a650-aa. I looked up junk yard and i only found crown victoria, grand marquise, and mustangs that came with 4.6l.

Does anyone knows if I can fit PCM from the ones mentioned above in my t-bird?

Is it only matter of pin-out matching between the PCM and the harness?

The t-bird has no PATS and I believe this can make it easier. Any one can help me with this I will be thankful.

Nabeel
nabeel11 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 10-19-2016, 07:05 AM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 54
Posts: 2,976
There are several 96 Mustangs that have a computer that is basically the same. You can probably most likely make them work easier though I have never done it to be able to tell you for sure.

Do you have access to the pinout diagrams?

Would it be easier for one of us to send you a computer? I have several.

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
post #3 of 16 (permalink) Old 10-19-2016, 08:38 AM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Darrin;
I found only 2000's Mustangs. No 96.
For the pinout diagrams. Yes, I have access to them.

Really it is good news to know that you have several. Indeed this is the best option. How much it'd cost me Darrin?

Nabeel

Last edited by nabeel11; 10-19-2016 at 08:46 AM.
nabeel11 is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 10-19-2016, 06:43 PM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 54
Posts: 2,976
I have an FTE1 which is the updated version of the FTE0 that you have. You are welcome to it for whatever it costs you to ship it as it's just wasting space here.

Figure out shipping and it is yours.

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
post #5 of 16 (permalink) Old 10-20-2016, 07:45 AM
PostWhore
 
T6Rocket's Avatar
 
Join Date: Nov 2004
Location: Raleigh, NC
Posts: 1,709
Darrin, if you happen to have any more FTE1's for a 1997, I'll buy one from you. Always good to have a spare.

If you do, we can take it to PM.

Thanks,
Al

97 T-Bird LX 4.6 - 80k miles
94 Supra TT Auto - street/strip car
04 CVPI- Brenda's car - 76k miles
Previous Fords:
95 T-Bird LX 4.6 - fully optioned, owned 15 years, 220k miles
96 Cougar XR-7 4.6- Brenda's car, owned 11 years, 187k miles
88 T-Bird 3.8 - first T-Bird, owned 5 years, 206k miles
T6Rocket is offline  
post #6 of 16 (permalink) Old 10-20-2016, 05:43 PM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 54
Posts: 2,976
I just have the one. I do have a couple of MBE3 though

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
post #7 of 16 (permalink) Old 10-21-2016, 07:27 AM
PostWhore
 
T6Rocket's Avatar
 
Join Date: Nov 2004
Location: Raleigh, NC
Posts: 1,709
I have a spare LJC1 that I ran for a while, CA emissions as I found out later. I thought I was getting worse gas mileage, so I swapped in an FTE1 I picked up, but mileage didn't really change. E10 woes, I guess. My catch code is FTE1.

Al

97 T-Bird LX 4.6 - 80k miles
94 Supra TT Auto - street/strip car
04 CVPI- Brenda's car - 76k miles
Previous Fords:
95 T-Bird LX 4.6 - fully optioned, owned 15 years, 220k miles
96 Cougar XR-7 4.6- Brenda's car, owned 11 years, 187k miles
88 T-Bird 3.8 - first T-Bird, owned 5 years, 206k miles
T6Rocket is offline  
post #8 of 16 (permalink) Old 10-21-2016, 07:35 PM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Quote:
Originally Posted by Darrin View Post
I have an FTE1 which is the updated version of the FTE0 that you have. You are welcome to it for whatever it costs you to ship it as it's just wasting space here.

Figure out shipping and it is yours.

D
Darrin;
Please check your inbox. I figured it out.

Nabeel
Darrin likes this.
nabeel11 is offline  
post #9 of 16 (permalink) Old 10-22-2016, 09:19 AM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 54
Posts: 2,976
Quote:
Originally Posted by T6Rocket View Post
I have a spare LJC1 that I ran for a while, CA emissions as I found out later. I thought I was getting worse gas mileage, so I swapped in an FTE1 I picked up, but mileage didn't really change. E10 woes, I guess. My catch code is FTE1.

Al

The MBE3 can be flashed to the FTE1. No promises, but let me see if I can rig something up and do it. I don't have any of my stuff I made to bench flash anymore, but I can make it again. Wouldn't be bad to have anyway. This WILL take time. Busy as heck here.

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
post #10 of 16 (permalink) Old 11-09-2016, 05:30 PM
Seasoned PostWhore
 
Darrin's Avatar
 
Join Date: Aug 2002
Location: Camby, IN 46113
Age: 54
Posts: 2,976
Hey,

If someone wants to help ship this then come and pick it up. I have been hit up 3 times now for paperwork and documentation to ship this outside the US. I am not going through that for a free item.

I tried to help, but I'm not assigning a value to it and I am not attaching my name, or company name, to international documentation on a free item.

D

01 F150 5.4L 4x4 and a 98 Mustang GT vert sitting engineless and without transmission or converter


All my vehicles tuned by BC Automotive (me)

Darrin is offline  
post #11 of 16 (permalink) Old 11-09-2016, 07:04 PM
Seasoned PostWhore
 
S4gunn's Avatar
 
Join Date: Dec 2010
Location: SF, CA
Age: 40
Posts: 2,576
Garage
Darrin:
If someone bugs you to ship something out of the country and you don't want to bother doing so, introduce them to a package forwarding service. When I sold a few items on eBay I had to deal with them as a seller and as far as I was concerned, I just had to ship to a specific commercial address and they took care of the rest.

The payment for the international forwarding/paperwork/etc was taken care of by the buyer (or in your case, the recipient).
https://www.shipito.com/en/
https://www.viabox.com/

there are a bunch of them.

My TCCOA iTrader Rating: (44 / 100% w/ 50+ transactions)

24 Hours of Lemons 2017 Sear Pointless Organizer's Choice
2018 Upgrade: does your TBIRD make Fritos? Mine does
http://goo.gl/csaet4
S4gunn is online now  
post #12 of 16 (permalink) Old 11-09-2016, 07:33 PM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Dear Darrin,
Please, don't get angry.

I tried my best to not to bother. I spoke to the shipping guys and insisted that they don't ask you any paper work. But it didn't worked out. Please accept my apologies for all the annoying stuff around this shipment. Really don't wanna be a jerk but I did.

However, it was nice Darrin to offer me this box for free. Thank you very much
If someone of you guys can advice or help I will be thankful.

Nabeel
nabeel11 is offline  
post #13 of 16 (permalink) Old 11-09-2016, 07:38 PM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Quote:
Originally Posted by S4gunn View Post
Darrin:
If someone bugs you to ship something out of the country and you don't want to bother doing so, introduce them to a package forwarding service. When I sold a few items on eBay I had to deal with them as a seller and as far as I was concerned, I just had to ship to a specific commercial address and they took care of the rest.

The payment for the international forwarding/paperwork/etc was taken care of by the buyer (or in your case, the recipient).
https://www.shipito.com/en/
https://www.viabox.com/

there are a bunch of them.
S4gunn,
What you said is true, but still, Darrin has to pay for shipping it locally from his office to the forewarder. And How I am going to pay him back?
The man is trying to help and I am bugging him :pensive:
nabeel11 is offline  
post #14 of 16 (permalink) Old 12-14-2016, 04:49 AM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
I have found one FTE1 from a cougar. Put it in and O2 problem gone. Now the problems begin. the RPM is not going over 3000RPM, once get there falls to 2400. O2 sensors status flapping from RICH to LEAN all the time

I am going to investigate this and get back with results.
nabeel11 is offline  
post #15 of 16 (permalink) Old 12-14-2016, 05:23 PM
No, Mr. Lemmywinks, No!!!

Moderator
 
Grog6's Avatar
 
Join Date: Jun 2005
Location: Harriman, TN
Age: 56
Posts: 9,861
Garage
Check fuel pressure; replace the fuel filter if you haven't already done that.

RPMs are usually spark plugs and wires:

pull the spark plug wires off the spark plugs, mark where they go.
Cylinder 1 is the one toward you, looking at the engine from the front, to the left side. 1234 is the left side, 5678 is the right.

look in the holes for coolant. if the intake leaks, it ends up here and causes this problem. You Have to both fix the leak, AND buy new wires.

pull the plugs. do this with the engine cold. be careful, and don't break any plugs. If you do, get all the pieces out before you pull the plug out.

clean and gap them to 0.54" (~1.4mm)

reinstall the plugs and space the wires away from the engine with something non-conductive and run it, and see how it runs.

Red '96 Cougar XR-7 240k mi. '02 4R70W, PST DS : '03 PI engine, 04 maf, 24lb injectors, 2.5" exhaust, '02 4r70w + Jmod, DirtyD0g TC + cooler + 3/8" lines, 255 walbro fp. Alpine system.
Black '96 Cougar XR-7 (Lazarus) 210k mi PI Intake, '02 4R70W, Jmod, PST DS, GrogTune, Konis, Mark LCA+Poly, racecougar Custom Engine Chain, and JL and racecougar Bracing.
Black '97 Tbird Limited Edition, '02 4R70W, 255 walbro, PST DS, PBR Brakes&SS lines, Toicko Blues & Springs, GrogTune.


"War Is Peace. Freedom Is Slavery. Ignorance Is Strength." - George Orwell.
Truth Isn't Truth. - Rudy Giuliani, 2018 Award winner, “Most Outrageous Diversion” by MSNBC for this quote
Grog6 is online now  
post #16 of 16 (permalink) Old 12-14-2016, 05:52 PM Thread Starter
Newbie
 
Join Date: Oct 2016
Location: Libya
Posts: 9
Quote:
Originally Posted by Grog6 View Post
Check fuel pressure; replace the fuel filter if you haven't already done that.

RPMs are usually spark plugs and wires:

pull the spark plug wires off the spark plugs, mark where they go.
Cylinder 1 is the one toward you, looking at the engine from the front, to the left side. 1234 is the left side, 5678 is the right.

look in the holes for coolant. if the intake leaks, it ends up here and causes this problem. You Have to both fix the leak, AND buy new wires.

pull the plugs. do this with the engine cold. be careful, and don't break any plugs. If you do, get all the pieces out before you pull the plug out.

clean and gap them to 0.54" (~1.4mm)

reinstall the plugs and space the wires away from the engine with something non-conductive and run it, and see how it runs.
Grog,
Thank you very much for the guide.
I have taken the tbird for a long ride and stick the scan tool. I have the codes in the image. P0171 & P0174. They indicates lean condition. Feul trim is in the range. O2 SENSORS seem to be OK. going to check feul pressure and replace feul filter as you said tomorrow and see how it runs.
Attached Images
File Type: jpg IMG_20161214_234115_1481759435732.jpg (125.8 KB, 5 views)
nabeel11 is offline  
Reply

Tags
4.6l , ecu , eecu , pcm , thunderbird

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TCCoA Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome